Bugs with Display modes and Grid in Rhino 8 WIP

I noticed that there are three bugs related to Display modes in the latest Rhino 8 WIP (8.0.23234.12305, 2023-08-22). One of them also affects the display of the Grid in “Ghosted” mode. I will add a brief description of each bug:


  1. Inability to hide the Grid in “Ghosted” mode:

  1. FilletSrf causes loss of shadows and material for the preview surfaces while using “Rendered”, “Arctic” or other display modes that utilize real-time shadows.

  1. Some crazy “Disco” mode that appears to happen on my custom display mode which I attach below. I haven’t seen that bug in older Rhino 8 WIP versions. The objects literally change their material colour all the time based on the camera orientation or mouse selection.
    Bobi 1.ini (13.8 KB)

Here is the file consisting those boxes and their materials:
Disco-like materials.3dm (209.7 KB)

I think this happens in any mode :sweat_smile: :sob: Need someone fix it :pray:t4: :pleading_face:

dang that’s messed up :sweat_smile:

hi @bobi, the bug with the grid is related to using a transparent grid in your display mode. The default ghost mode should not have this bug

RH-77385 Drawgrid and DrawAxis options in Shade are not working when using a transparent grid

I couldn’t repeat the flickering materials issue you are seeing here. Is that still an issue?

As for FilletSrf, yes it looks the previews are doing something to the shading, I added:
RH-77386 FilletSrf and related commands preview shading issues

2 Likes

Hi @Gijs , seems like I forgot to reply here earlier. I just discovered the reason why I see that strange bug. It happened again now when I did the following steps:

  1. I removed a custom display mode from Rhino settings > View > Display modes > Delete. Once I did that, I forgot to press the “OK” button at the bottom to close the pop-up window!

  2. Then I deleted the *.ini file of the same display mode from the folder where it was saved, while it was still active in the viewport in Rhino 7 (since I forgot to press the “OK” button, as mentioned above). For some reason that preserved the display mode inside Rhino 7, despite the its *.ini file no longer exists;

  3. Then I repeated step #1, but this time I removed the display model and clicked “OK” to finally remove it from Rhino 7.

  4. This seems to corrupt the file forever (I didn’t saved it after the removal of the display mode), because the bug with random disco-like lights and real-time reflective environment map showed up again upon the next start of Rhino 7 and opening the same file.

The latter looks like having the same bug which I reported in another topic:

1 Like

What’s the plan here? This grid bug is very off-putting every day I use R8.

1 Like

From what I can see, it is fixed:

Checking…

Not fixed.

Alert: grid bug. :coffee:

Still a bug:

hi @lander can you export that display mode and send it to me? Because I can’t possibly guess what is different in your setup that it doesn’t work at your end, thanks!

Well I tried many times explicating it clearly with paint shop imagery, but maybe I left too much up for interpretation.

So, I’ll be more specific going forward on this matter.

I believe any display mode has the same problem as long as you use the particular settings that reveal the problem, but here is one particular mode I’ll share for now as an example:

grid_bug_example.ini (14.7 KB)

This is my only possible workaround for this silly bug:


Sense the whole list under “grid appearance” is comprised of nomenclature that doesn’t make any sense, I basically have no choice but to use “show grid on top of objects”.

In previous versions of Rhino, I’ve been using “transparent grid”, but I guess that option wont work anymore.

If only the grid and the axes were treated separately, then I’d have more control over the visibility of each separately. But that’s probably too advanced of an idea for a GUI. :smirk:

I’ll do what I can to accept this hurdle for now, but a bug is a bug is a bug, soo…


I’ll see if I can get by with this alternative for now, but ‘transparent grids’ should still turn off when you tell them to – imo.

Hurdle version:

grid_bug_hurdle_example.ini (14.7 KB)
:expressionless: ‘transparent grids’ don’t turn off :white_check_mark:

Feel like I need to boot up windows xp and review V5 again to see what changed… :sleepy:

Maybe what I’m seeing here is a flaw in nomenclature ideology:

Explain why a transparent grid of 0, should be “on top of objects”? That makes no sense.

Well I just noticed something. Maybe @Rhino_Bulgaria already pointed this out…

Transparent-grid-of-0% bug.

R9 wish: The grid and grid axes need a serious upgrade.

There should be more options, and the features should be more logical and intuitive.

The XY and Z axes should be in the same dialogue and be seperately controllable from the grid.

Thickness, length, transparency etc. – imo.

1 Like

thanks @lander for the sample,

I see a couple of bugs and yes that UI is pretty bad, I’ll write up the right YT for this.

RH-78726 Grid settings issues

2 Likes

Hopefully that Rhino 7 will also receive fix of these bugs. :slight_smile:

1 Like

Ikr.

I just wanted to leave this ugly picture of these axes with these new settings I’m trying to use to mitigate the issue:

Unfortunately I think our only hope is R9 :sleepy:

At least (me) being an aspiring development “chump” :slightly_smiling_face: makes me feel more entitled to complain alot :sweat_smile:

I hope ppls can handle my complaints going forward :smiley: :beers: I’ll try not getting ‘too’ outa control :upside_down_face:

Rhino for life :star_struck:

Upgrade though :grin:

1 Like

That seems another issue than the ones I logged. I could not repeat that behavior here, so if you have a (simple) file and/or the ini that shows this, I’d like to have a look, thanks!

1 Like

weird_grid_axes_fade_ontop_objects.ini (14.1 KB)

looks like the shade or shadows do alter the effect or something:

I was working on another thread and stumbled on anew way of seeing these bugs in active detail views:

Some of the video might be slightly misleading as I noticed the grid was on, but some reason the grid settings are much different in an active detail view rather than the normal Rhino viewport:


Really weird inconsistent GUI settings … :thinking: :thought_balloon:

How do I get the active detail view to embody the same characteristics as the normal viewport …

Maybe the active detail view uses some generic cplane idk :sob: