BUG: selected SubD gets dark in Shaded or Rendered mode

Hi RMA team,

I’m using build Work In Progress (7.0.19204.8205, 07/23/19)

When I create a SubD primitive and I select it. It’s shading turns darker.


one more display problem with SubD: There’s no way to display (and take screencaptures) of SubD models without showing the wires.

You can see here that the surface edge settings are kind of hooked up (color is hooked), but if I set the thickness to zero it does not work:

We are working with a lot of SubD models (mostly imported from Tsplines/Modo for now) and we cannot take any screenshots without wires in either shared or rendered mode. For now our workaround is select all SubD, extract rendermesh and hide the SubDs.

If you guys can fix this sooner that later we’d really appreciate it.


Hi Gustavo,

Do you still see the dark shading on selection in the latest v7 WIP? If so, is it in all shaded display modes or just some and are those modes set to defaults or customized in some way?

The edge display issue with subd is fixed and should be in the next v7 WIP to hopefully come out next week. Essentially display modes will have subd edge settings. I’m waiting on a build of the day now to make sure it’s working. (RH-53624)


Hi Brian, Latest public wip installed today.

Thanks, please post or send me your ini for Shaded mode using the Export option in Options > View > Display Modes and selecting Shaded in the list. It looks like you have custom settings that are causing this in that mode on your system. Run the SystemInfo command as well please so we know the GPU and driver date. Thanks again!

system info:
Rhino 7 SR0 2019-7-31 (Rhino WIP, 7.0.19212.04535, Git hash:master @ 359a2f7b33a838bbf03af3c3508db8c3f06f69a5)
License type: Commercial, build 2019-07-31
License details: Cloud Zoo. In use by: Gustavo Fontana (Fresco Design)
Expires on: 2019-09-14

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: G7720

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P5000 (NVidia) Memory: 16GB, Driver date: 11-1-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 416.78

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-1-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16 GB

Rhino plugins
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.0.19212.4535
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.19212.4535
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.19212.4535
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\MeshUtilities.rhp “MeshUtilities” 7.0.19212.4535
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.19212.4535
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.19212.4535
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\OctaneRenderForRhino (f109bd23-4cf3-4c0b-9f83-06be474b0152)\\RHI Installer 6\Rhino 6.0\x64\OctaneRenderForRhino.rhp “OctaneRenderForRhino”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Users\gusto\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2018.12.17+906\PanelingTools.rhp “PanelingTools”

viewmode attached:
GF_darky_shady_Shaded.ini (11.9 KB)

Thanks. I’m not seeing the issue here but have several ideas that might fix it on your end. Does enabling this help…

If not, does turning off shadows make the issue go away?

Last thought is to update your driver. See the Notifications panel in Rhino’s Panels menu to get a direct link to Nvidia if needed.

Problem is gone now. Without making any changes. No Idea why. I’ll update drivers anyway. I’ll report bacj here if the problem comes back. Thanks!

Okay, thanks for letting me know.