Backup file created when they shouldn't be

I’m not sure what changed, but for the last month or so I’ve been getting .3dmbak files when I save. I don’t have this turned on in the options, yet it happens all the time now.

Is there another place that this is being controlled? I would like to shut that off.



Another user reported that 3dmbak files were being generated when overwriting existing files. I guess you are not using SaveAs and using an existing file name but perhaps there is something going on with saving on the network. Do you also get that when working and saving a file on the local HDD?

I’ve seen this here when saving on a network drive; the system doesn’t allow Rhino to erase its temporary files as fast as Rhino is trying to, I can erase the files only after I wait for a few seconds.

I had to give up saving to a local ‘partition’ that was being mirrored real-time on a network server because of those speed issues. I have the 3dmbak option turned on so I didn’t notice this side-effect but it definitely sounds like a plausible cause.

Yes, I get this too when saving files to our network, despite the fact that I have .bak files turned off… I reported this many moons ago.


Yes, that’s primarily where I’ve been noticing this.


A question Dan, why you don’t want bak. Files? Trying to learn. Thanks,Mark

We don’t need them. They just create clutter that needs to be cleaned out on a regular basis. We used to have thousands of bak files from our Autocad days. What a pain. We had to assign a person to search and clean them on a weekly basis. I know hard drives are cheaper now, but we still don’t want to be upgrading our servers just to handle files nobody wants or needs.

I understand the purpose behind them, it’s just that, for whatever reason, it doesn’t do anything positive for us.


1 Like

Yep… --Mitch