Another update another load of printing bugs!


(logikman) #1

What is it about Rhino servcie release updates .I use a lot printing to PDF for distributing to none rhino users, The first verison of Rhino 6 worked (sort of) but the the print “bitmap” (used for logo’s in title blocks ) did not work (ackowldge by Mcneel). The bitmap logo did not appear in the print preview but did print out in either my preferred PDF printer (cutepdf writer) or in the one supplied by Rhino itslef . The Micorsoft PDF (printer) has never worked in any service release of Rhino 6. So now we have Rhino 6.6 dated 26/06/208 and this really takes the biscuit" Now when I create a new entitiy in a model that used to print fine to PDF using cutePDF writer the new entity simply “disappears” on the PDF print out even though the layer is set to print ok. TO check it was SR 6.6 that was the issue I left my rhino 6 on my laptop at the previous service release. From that version the print to PDF works fine other than as already posted where the bit map does not show in the preview but at least it prints out in the PDF and all entities show ok in the preview and they print out ok. Opening the same file in SR6.6 the new entities drawn in SR6.6 simply disappers on the PDF print out. Its the same with the prinmetr "Rhino PDF2, Cutepdfwriter and the microsoft PDF printer.
So once again an update has wasted another 3 hours of my life trying to work out a way round this rather basic function. As it is I am not updating the laptop version (evne though it constantly nage me to do so) and I so edit the the model on my main machine (which is much faster and 32Gb memory) and then network the file to my laptop to open it up in the previous service release to print it out, wher ot prijts our fine, Very tedious but it seems to be the only way round this issue at the moment.
Whilst I appreciate the added bells and whistles of SR 6.6 if basic functions, like printing to a PDF are lost by whatever has been changed then the software becomes very challenging to use, and I am glad I kept versions 4 and 5 installed on my lap top.
I have been using Rhino since version 3 and the last 3 service release of Rhino 6 have been an absolute nightmare with several issues that makes the software very challenging and time consuming. PLEASE make sure when you issue Service releases they are tested for basic functions like printing to PDF and I for one will be a lot happier. As it is can anyone tell me how stop Rhino nagging me to upgrade my lapop version untli this is sorted out.

Logikman


(Steve Baer) #3

I’m sorry to hear that this has been your experience. I’ve been making fixes in the PDF printing that have been reported by users lately and it sounds like there was a regression that we missed which you are seeing. We treat regressions as a top priority and I haven’t heard of this specific issue before. If there is any way you can share your model with me so I can try and repeat what you are seeing, I’ll try to fix it right away.


(logikman) #4

RHINO SR6-6 PRINT ISSUES.pdf (1.0 MB)

attached is PDF of the issues. So far its not just the PDF print but the printing to hardcopy too.
The full model is the subject of a confidentiality agreement so I cannot let you have access to it in open forum.

the fact is print side of Rhino 6 is a mess and simply needs to be sorted BEFORE a service release is published. As I said if the basics dont work (and printing is a pretty basic need) the rest of the “improvements” are pretty much worhtless !!

what I can tell you is that creating new model in SR 6.6 and prinitng out from a layout with not title block seems to be ok, Its only prevous models where entities are added in SR 6.6 where I get the problem. If I print out an unedited earlier mode; to PDfF its fine ?? VERY FRUSTRATING !!!

Logikman


(Steve Baer) #5

Can you send me the model privately to steve@mcneel.com? I typically need the initial model to figure out why the bug manifested.


(logikman) #6

Is there anyway to get back to
Version 6 SR6 (6.6.18168.12081, 17/06/2018) or a link where I can download it and reinstall it ??

Version 6 SR6 (6.6.18177.16151, 26/06/2018) seems to be what is causing all the problems

I have tried reinstaling windows and a new clean version of the orignal SR6 6.1.18037.13441, 06/02/2018 and AS REPORTED then the print function does not print out logo’s (ie: background Bimaps) as already acknowledge by McNeel.

I still have SR 6.6.6.6.18168.12081, 17/06/2018 on my laptop and ths prints fine to both PDF and Hardcopy with both backgound bitmap and detail winows prinint fine
.
Rhino then updated to 18177.16151, 26/06/2018 and this does not print backgound Bitmaps to anything (PDf or Hardcopy) and omits to print any detail window in layout that contain an entity created in 18177.16151, 26/06/2018. It does print out any detail window containg an entity created in SR 6.6.6.6.18168.12081, 17/06/2018 ???
.
BRING BACK RHINO 5 or AT LEAST provide a roll back funtion in SR6 (at least until you have it wokring properly). to undo the damage this dodgy Service Releases has generated, am I alone in having this problem ??

Logikman


(Steve Baer) #7

Here is a link to the SR6 release candidate 6.6.18168.12081
http://files.mcneel.com/dujour/exe/20180617/rhino_en-us_6.6.18168.12081.exe

I think your case is pretty isolated as this is the first report I’ve heard of for this specific bug. This is also why we didn’t catch the bug during our release process.

I was able to repeat the bug with respect to the bitmap not printing and am investigating this issue. It has something to do with the bitmap being inside of a block as when I explode the title block, the bitmap prints.

I am still unable to repeat the problem with the details not printing. The model you sent me has these details showing as if they were in wireframe display mode which doesn’t match what your PDF results display (they show as shaded display). When I switch the detail to shaded mode they so there must be something else going on. I suspect the object may have had its display set with SetObjectDisplayMode and am still investigating this.


(logikman) #8

Thanks for the link

Still does not work on my workstation and does the same the thing.

The only difference between the laptop and the workstation is that the laptop runs it windows 7 professional and the workstation Windows 10 professional.

They are both now running 6.6.18168.12081 so maybe it’s the last windows 10 update that’s caused the problem ??

On the workstation I did a compete uninstall of Rhino 6.1. Then ran a registry cleaner to remove any remnants, then a clean install of 6.6.18168.12081

And still it won’t print the logo or the pen with hidden lines details !!!

I give up. !!! and it’s way past bedtime.

Kind Regards

Lee A Roth

Technical Consultant

Technical Advice for :

  •     Ecclesiastical & Listed Building Bespoke Glazing
    
  •     Fire Rated Glazing
    
  •     Acoustic Privacy and Acoustic surveys
    
  •     Advice on related Product Design & testing.

(logikman) #9

Dear Steve

I think I have now got it working but only to Print to Cute PDF Writer and to hardcopy.

I reinstalled windows 10 keeping personal files and settings

I changed ALL McNeel folders in Appdata to McNeel (old)

I then installed 6.6.18168.12081

During the install I got this error message

But it did carry on installing when I clicked OK

I then imported my settings file (07072018 rhino settings.ini) to Rhino

Opened a rhino file I created on my laptop

Printed to Cute PDF Writer and no logo came out (“background Bitmap”) and it did preview with no logo showing.

I then went into Display mode settings and changed all display modes to show a white background.

I noticed when I changed the PEN display mode the area around the layout page changed from grey to white (don’t know if that’s significant or not)

I then printed out to Cute PDF Writer and everything came out as it should.

I then opened the test file I sent you and……………….it printed to Cute PDF Writer fine. Logo and ALL the details.

There is one gremlin that may be something to do with the error message I got. There is no print Preview in the print window at all when I print to Cute Pdf Writer. The “progress” preview shows when Print is clicked button as a small window as the PDF writes but that’s all.

You may find this next but confusing…….I KNOW I am !!

When I select print to a Brother printer the Preview does appear, and when I go back to Print to Cute PDF Writer the preview stays showing ??

If I click “close” (bottom right corner of print page) and reopen print with Cute PDF Writer as default the screen preview disappears again ???

If I click “close” and reopen and print to Brother then exit the model and then open again the preview screen is blank again when the destination is printing to Cute PDF Writer and only reappears if I close and select Rhino PDF as the destination for the Brother Printer ???.. then when I close and reopen the screen preview shows when printing to Cute PDF Writer ???.. it seems the fault is binary and is either on or off on each subsequent opening and closing of the print screen ??

If you close with Brother selected as the print destination and then reopen with print destination as Cute PDF (the default) and the preview shows ok.

If you close with Cute Pdf Writer as the print destination, then exit the model and reopen it sometimes shows the preview screen and then sometime does not !!!. so this is a very erratic problem.

I also tried printing to “Rhino PDF”. This does show the preview but with the missing “background Bitmap” logo.

This prints the details ok but still does not print the “background Bitmap” logo

I also tried printing to “Microsoft Print to PDF”. This does NOT show the preview and the “progress” screens just shows a green rectangle.

When the PDF saves it has 0 bytes and is totally blank.

SO apart from the erratic print preview screen we are nearly back to where I was on Thursday !!! just 8 more programmes to install on the work station !!.

I am now going to uninstall Rhino install all my programmes and then save a disk image before reinstalling Rhino.

Kind Regards

Lee A Roth

Technical Consultant

Technical Advice for :

  •     Ecclesiastical & Listed Building Bespoke Glazing
    
  •     Fire Rated Glazing
    
  •     Acoustic Privacy and Acoustic surveys
    
  •     Advice on related Product Design & testing.
    

I


(Steve Baer) #10

Hi Lee,
I believe I got the printing issues fixed for what you were seeing in SR8. We just released an initial release candidate for SR8 today

https://discourse.mcneel.com/t/rhino-6-sr8-release-candidate-available/


(logikman) #11

Dear Steve

Got around to trying this SR8 and STILL does not print the logo in the title block (my original issue).

So will once again uninstall and reinstall SR 6.6 that does work.

Lee Roth


(Steve Baer) #12

Thanks for testing; I’m sorry to hear that this issue is still happening for you. I am getting the “envision4glass” logo in my tests with SR8, so I must be not performing the same tests as you.

Can you send a screen capture of what your print dialog looks like when you try to print?


(logikman) #13

Dear Steve

Gave up on SR8 removed it all and back on SR6.6 now as this works albeit there are still a lot of gremlins.

For example it draw a simple “L” profile extrude it to create a simple “L” shaped bar and you move one end face at end of one leg, the corner at the 90° fold moves with the end face distorting the angle ???

when I have few hours to spare I will try your SR8 again but not sure it’s worth it at this time as I am trying to get a new product launched and this is really wasting my time right now

Lee


(logikman) #14

Dear Steve

Solved the logo issue

The original Rhino 6 release used the menu : surface, plane, picture from the menu system. To import bitmaps for use in Title blocks.

In the latest version 6.8.18230.16521. I have had to go into the title block entity (that I use as my title, border and drawing info block) and delete the surface created in the old version and replace with using the command line “picture” command to create new bitmap.

This now appears in the print preview to CutePDF and prints ok to a PDF showing the logo correctly.

As the same title block was used in all layouts I assumed this would simply update the Title block on all layouts ……WRONG !!.

I have a 7 layout Rhino file and for some reason in layouts 1,4, and 5 the logo did not appear.

After a lot of trying I ended up going into each layout, deleting the title block; then copying [ctrl C] the entire layout, THEN creating a new layout, THEN [ctrl V] to paste the original layout into the new layout, THEN deleting the old layout and THEN FINALLY renaming the new layout to the one I deleted.

Having done this the logos now appear correctly………………VERY LABORIOUS. !!!

Also 6.8.18230.16521 seems to have resolved another issue that I had where when I printed “all layouts” when the layout contained a perspective detail view; where the perspective tail appeared in diminishing sized ghosts of the 3D detail across the page.

Lee Roth


(Steve Baer) #15

I’m happy you worked around the issue, but I was also hoping to try and figure out the problem without forcing you to go through these steps. The printing code evaluates a surface and tries to determine if it can print the surface as a planar bitmap in vector output mode. For some reason the print as bitmap test was failing on your system and passing on mine. This was why I was trying to get a screenshot of your print dialog.

If the problem crops up again, please let me know.