Bug: Pdf, View Capture, Render - larger Format

when i set to raster, anything larger than A1 (or lets say when one of the sizes exceeds exactly 920 mm) distorts/multiplies the content. i even deleted my printer to see if that had anything to do with it.

i also set up a fresh randomly filled file and the problem persists. vector would print, but that is not printing textures unfortunately. my files were set up from a standard template large cm

View Capture to File:
seems to behave similar, i did not have time to investigate the exact size but setting it to about A0 by 200 dpi output a strangely content similarly multiplied distorted file.

it seems Rendering an image in a bigger format is also not possible, duplicating half messed up instances into the file.

guys, i have no option to output my file really… that is super urgent now i am stuck with a file i worked on for days and cant get it to print!!!

well i found a workaround for now, exporting and opening it in my expired 6 evaluation allowed me to at least print as a pdf with a seemingly similar result.

also Rhino 5 seems to output it, but textures look different and not very good in that regards, the only additional method for rhino 5 would have been to render it with skylight not to have shadows, but that takes forever. so currently printing with version 6.

Hello - can you describe the symptom more clearly or provide an example? I am not following, at all, what goes wrong.


open any template, draw a rectangular or anything visible over the cplane, go to print, raster output and a paper size for example A0, the rectangular gets scrambled up even in the preview. anything bigger than 920 mm either side. this is also true for render, and view capture to file/clipboard

here the random file i just created if it somehow helps. Untitled.3dm (2.8 MB)

Hello - so far this looks correct here .


which size did you set the print? rhino 5 and 6 both work correct, rhino 7 does not output anything bigger than described properly. not sure if i cant describe the problem or if yours just works…

this is my output when i try to view capture to file with a size of 930 mm in the width

@pascal did you use scale to fit? also i have a laptop which is closed using a bigger external screen as a main screen.

Hello - I did use Scale to Fit (though it does not, really)


i think you would have to select extents then, but it is odd that mine does not work, though all other versions work correct.

there is still no progress here? not being able to print out larger prints. trying to print this

results in this

@wim @jeff i just downloaded an update 7.5 which might have to do with this.
i assume it is still not fixed?



Can you please provide an example file? With the latest changes I can print a 8’ x 6’ @ 600dpi to a PDF without issue, and that’s on a low-end 2013 MBP… so I’m not sure what’s happening on your end.

I’d like to use the exact file you’re using if possible.


I will try the example file in this thread to see if that works, but I’d still like the file you’re working with and all of the settings it uses.


hi Jeff, thanks for checking in

i have a late 2013MBP with →

regarding file, it is practically impossible to print with any file, using any random template here now small objects mm with the following settings (so mainly larger formats dont print a4 does work still)

here the file Untitled.3dm (4.3 MB)

it is set to print as raster (print as vector seems to work) but export as pdf vector or raster neither work.
also ViewCaptureToFile does produce this but also rendering it, and by the way it also does not output the requested jpg it seems stuck on png.

also here a topic from a different user in which i have collected reports from different users.


I’m still not seeing this problem on any of the Macs here…However, they’re all updated to the latest OS (Big Sur 11.2)… Is there a reason why you haven’t updated? (at least to Catalina?)… I’m not saying that’s the cause or reason here, but so far, the only differences between your 2013 Mac and the one I have here are:

  1. Yours has an NVidia GPU, mine has an Intel
  2. Yours is using a very old OS (Mojave), mine is using the latest (Big Sur)

…either of those could be the reason. But without being able to reproduce the problem, I can only speculate and guess as to why you’re seeing what you’re seeing.

The other problems mentioned in the other post should be fixed in 7.5…I have verified that the example file provided there also works when printing/saving/capturing at very high resolutions… On iMac and two different MBP models… However, I do not have the example MBP you have, but I’m currently checking to see if anyone at McNeel does.


And just to assure you that I’m not blowing smoke :wink: … Here are some clips showing me doing this on my very old 2013 MBP with Intel GPU…

hi Jeff, please try a bigger size, with your values i get a normal result either. for example try 1000mm x 1000mm. does that still work?

regarding update, yes i was working on several projects for a long time and updating in between felt a bit risky, but they are finished now and i will look into updating the operating system anyway but do you suspect that this really could be the issue? and if so rhino should also work on an older system i think.

Yes, those sizes also work… I’ve gone as far as 8’ x 6’ @ 600dpi (2400mm x 1800mm) and it works… It generates almost a 1GB file, and it takes a bit of time…making a recording of that would create a .MOV larger than the maximum size I can post (20MB)…otherwise I would have shown that.


hi jeff, good news:
it seems that the issue has vanished upgrading to big sur, i guess you should UP the minimum requirement for rhino or fix this bug for mojave.

bad news:
oh man does big sur look ugly… those big title bars in all the apps and windows? really? OH EMM GEE… i did not have any option to update to catalina, should have grabbed a version from the net somewhere … also rhino works super strange, in wire everything jitters in a weird frequency it does not seem to be optimised, good that i have a bit time to skim the web for soothing hacks… :see_no_evil: :speak_no_evil: :hear_no_evil: but i guess rhino has some issue with older macs?

I would say that it’s more accurate to phrase it as:

“Rhino has certain issues with some older Mac configs”

My MBP here is just as old as yours, and V7 runs pretty well on it. So saying a blanketed statement like “has issues with older Macs” isn’t really accurate. It’s unfortunate that you appear to have one of those configs.


well, i did not mean to blanket it. maybe yours is a wee bit more common since it was just the cheaper deal, but my config is a really not that exotic. those graphic cards were used till 2014 before they where replaced by amd. i had one of those 2015 models but they got hot so fast so i stayed with the 2013.

i am just waiting for rhino to get a green light on apples M* series, switching is a very imminent aspect. you dont have any plans to update? i mean not that its really needed, they are good computers.