Bug ? Label of ClippingDrawings


Quick test about clipping drawings and I’ve found a small discrepency.
I was curious why the text dot was selectable in the 2D section since all the layers are locked.
Then I tried to remove that dot and nothing happens. Until I decided to add it back and discovered there were now two of them, the new one being unselectable !

I’m not able to reproduce your issue, I’m running the latest build (Today’s release)

Tested with this week’s release 8.0.23199.14305, 2023-07-18 and the bug is still here for me.
The dot seems to always be created on a Default layer, no matter what layer is active or where the clipping section is located.
If I delete the Default layer it gets reinstantiated when creating the drawing for the first time with ShowLabel = Yes.

@magicteddy I cannot reproduce this behavior here, pls run SystemInfo and post back the results.

Rhino 8 SR0 2023-7-18 (Rhino WIP, 8.0.23199.14305, Git hash:master @ a6883672b69b1cbc08ccd6a0cf2095f93971b440)
License type: Commerciale, build 2023-07-18
License details: Cloud Zoo
Expires on: 2023-09-01

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 5-26-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3050 Ti Laptop GPU (NVidia) Memory: 4GB, Driver date: 1-28-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 511.65
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-28-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\maxim\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\EleFront\4.2.2\ElefrontProperties.rhp “ElefrontProperties”
C:\Users\maxim\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\Chameleon_tools\1.0.6\Chameleon.rhp “Chameleon.tools”
C:\Users\maxim\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8 WIP\Plug-ins\Commands.rhp “Commands” 8.0.23199.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.23199.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.23199.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 8 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8 WIP\Plug-ins\MeshCommands.rhp “MeshCommands” 8.0.23199.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.23199.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoRoslyn.rhp “RhinoRoslyn” 8.0.23199.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.23199.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCPython.rhp “RhinoCPython” 8.0.23199.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.23199.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8 WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8 WIP\Plug-ins\Calc.rhp “Calc”
C:\Program Files\Rhino 8 WIP\Plug-ins\SectionTools.rhp “SectionTools”

I tried to disable all third parties. Same thing.

@magicteddy can you disable the plugins that don’t ship with Rhino and see if the problem persists? Those I would want to rule out first.

1 Like


sorry, missed that last part :face_with_peeking_eye:

@magicteddy can you send me a file that shows this behavior? I want to see how it opens here.

Just reproduced it with a simple box from a new file.
Hope this helps…

ClippingSection.3dm (61.1 KB)

This is still repeatable for me on today’s build.
Steps from a new file.

@magicteddy I see it on your file, but cannot repeat the behavior unfortunately.

Just a wild try, can you perform a OptionsExport and send me the resulting file?
Did you try a factory reset (_Reset) (first make sure to back up you settings with the above)
Another thing I can think of is that this a localization related bug, but let’s first try these.

I just did a Factory reset. Rhino WIP started in French and I have the bug immediately.
I’ll try to uninstall French language pack, then factory reset, then test again in English.

Edit : done, same thing.

Here are the options but it doesn’t seem to come from this.

backupWIP.ini (179.6 KB)

Ok, what are your regional settings?

Is this what you are asking for ? French everywhere. I guess I’m up to install US regional settings and try it ?

thanks, no need to do that right now, let me first try the other way around…unless you can’t wait :wink:

1 Like

Still not repeatable


I suspected this would be W11-related, so I just installed Rhino WIP on another computer where it was never installed before, running W10.

I’m running French environment and French language and I instantly got the same issue.
Switched to English language and factory reset… Same thing.
I’ll try to switch to English environment later on → done and still seeing it.

In addition, if I move the clipping plane, a second label appears and is locked (in the correct layer).


@magicteddy I managed to repeat by changing the language and region settings as well as installing the French language pack

:clap: :clap: :clap:

A step closer to identifying the problem. Thanks !