Bug, feature, or me? Pan parallel view option not working

This worked great in Rhino 5, especially when training new students. We would activate the option Always pan parallel views = ON [see below] and then you could not rotate any ortho view and get it all funky.

Now, any ortho view will get messed up when using the mouse right button + CTRL + SHIFT.

Please advise. I’m in the middle of another LinkedIn Learning / Lynda course and the beta testers are saying I blew it. Ouch.

Running Rhino 6.6 on Windows 10

Hello - Ctrl-Shift-RMB always breaks the plan view - v5 and V6. What ‘Pan parallel views’ does is, once the plan view is shifted out of plan - but still parallel - RMB drag pans and does not tumble the view. As far as I can see this is working in V6.


Hey Pascal

You are right … I never caught that subtle difference. BUT … shouldn’t the setting work as I suggested? That would be awesome / technically correct / and more consistent.

In other words, can you think of a reason someone would ever want to ‘funkify’ an ortho view? This really slows down beginners.

Hi Dave -

Well, I do it all the time - to see more clearly but keep the current CPlane active - but it takes a pretty deliberate action so it should not happen by accident very often…


1 Like

Sorry, dude. You are too good! Its the curse of knowledge.

My beginning students, whether in school or corporate training, have this problem fairly regularly. As we all know, navigation is critical. Then, we have a rule that only applies about half of the time … so its no longer a rule.

Maybe I would feel differently if the option DID NOT say “always pan parallel view…” and instead more accurately said “will occasionally pan parallel views, so not sure why we even have this option. Have a nice day, nerd!

Hi Dave - How? They need to Ctrl-Shift-RMB to kick out of Plan - right? or is there some other way they get the view whacked?


Hey Pascal

Let me see if I can explain this better …

So, beginners learn that rotate in perspective works great, but when they accidentally do the same command in any 2D viewport, its gets warped. If they spot the option “Only pan parallel view,” they think its fixed. It’s not. In their minds, you should not be allowed to ‘break the interface.’

Remember, people are learning and have no frame of reference. They are doing the wrong thing ALL the time – and not even realizing it. Sometimes, students won’t notice their ortho view is a few degrees off. I’ve seen them do work for a while … and then its all distorted … and they have to throw away work and start all over. I usually spot the problem before they do!

I totally get that this does not make sense to an expert like yourself. Me neither. But, I have to adjust to my students and this is a long-running and constant source of confusion.

You are right that there is a use for rotating an ortho view. I am not sugesting doing away with it. It should just be a lot harder to do accidentally. I suggest an option listed under the viewport label ‘rotate ortho view’ or ‘unlock view rotation.’

I hope that helps.

Is there some portion of your course that tells students to hold down ctrl+shift? Just curious

No. I don’t tell them, Rhino tells them! Its directly integrated into the interface. See examples below.

Any further updates? If you Mcneel guys are considering this as a potential future fix, hey, let me know.

Hi Dave - no, no updates that I know of. As far as I can see the behavior is pretty straightforward and predictable. Ctrl-Shift-RMB rotates a view, period-if you don’t want to rotate the view, don’t do that… right? . The ‘Always Pan’ setting applies to the RMB-drag. It seems to me changing this behavior would be a horrible breakage of perfectly reasonable behavior.


1 Like

OK, cool, thanks for listening. You must train superior students to me! :slight_smile:

I’m with Schultzeworks on this one. I commented on this years ago pan should always pan a parallel view, why when in a plan mode would one want to ever leave it on accident. I hate this caveat and the fact McNeel doesn’t fix it. Maybe the setting should be kind of always pan parallel views or use at your own risk.
The reason I say this is because I have too often hit that key combo on accident.
Here is the cure undo view but come on this should work as advertised.

1 Like

I work almost exclusively in funkified views. Never in perspective, always a rotated top view.