Keep orthographic view from orbiting


Is there a way to keep the camera from orbiting in orhographic views? I have it set to plan mode, and the projection is parallel, but I keep accidentally orbiting. It used to work like this when i started using it (a year ago), but now, I’m orbiting in all ortho views. Thanks!

Hello - a plan view of a CPlane should not tumble with RMB drag but it will with the RotateView command. How are you tumbling the view? You can set ‘Always pan parallel views’ in Optiions > View page but that is more restrictive.


I accidentally tumble if i accidentally click alt + middle mouse button (I’m toggling heavily between Maya and Rhino, so my navigation gets screwy). I do have “always pan parallel views” checked. I don’t use rotateView at all. It wasn’t always like this.

Hello - check how things are set up on this page:


This is what i have. It’s almost the same except for swap pan and zoom (FYI - I tried to uncheck that, but still doesn’t lock ortho views either)

Hello - testing here, I have two Logitec mouses that, so far, behave differently from one another - one works exactly as expected and as you expect, and one does nothing useful at all on MMB-drag - it just slightly changes the zoom level. This last is thew fancier mouse, with more stuff on it, but I cannot so far get it to obey the MMB setting in Rhino. I can set a side button to behave like MMB however… In any case, panning is consistent when it happens - it does not tumble an ortho view. What mouse do you have?


Hello. I have an HP mouse. Most likely the standard stock mouse from the box.

OK, here, with the second mouse that behaves as expected, I now see plan views tumble with Alt and that is indeed the expected behavior with the settings you show.


How do i set it so that plan views don’t tumble with Alt + MMB? thanks.

You cannot, as far as I can see -


My primary mouse is not paying attention to this setting so far anyway, so I was having a hard time reproducing the behavior…


Are you able to give it a setting so that the camera doesn’t tumble in ortho view? I can imagine many users would find this useful to lock in ortho views so they don’t behave this way. Thank you!