BUG: Dimensions are visible through the walls

I noticed that there is a bug with the dimensions that make them visible through the walls, which happens when you go to “Rhino options > Annotation styles > select some of the existing styles > Font > Mask” and choose “Background” or “Solid color”.

The solution is to NOT use those two options that will damage the dimensions! Users must always avoid them and use the “None” option instead. Once that is done, all future dimensions of the same style will no longer be visible through the walls.

The problem is that dimensions that were once built with “Background” or “Solid color” and were visible before, remain visible even after I switch to “None”. It’s really annoying. The solution only affects the dimensions built afterwards, while old dimensions remain damaged.

Until the bug is still active, here is some more clarification about a temporary solution:
In the future, if you want to have dimensions with background, you should add it after you build them without background. Once you build some dimensions, select them, open the Properties panel, navigate to “Mask” and change from “None” to “Background” or “Solid color” (whichever you prefer). Once you do that, the modified dimensions will act just like the regular dimensions and won’t be seen through the walls.

Hi Bobi- thanks, I’ll take a look at this.
RH-77642 Dimension - masking glitch


1 Like

Hi Pascal, I think that observing the cause of this particular bug may lead to adding a new option for the dimensions to make them visible through walls. :slight_smile: This is actually helpful in certain situations.

Hi Bobi - BringToFront/ClearDrawOrder should help here. Incidentally, that (clearing) seems to ‘fix’ the objects in your original report.
And… masking seems to be broken in 8.

1 Like

Hi Pascal, the ClearDrawOrder command placed the dimensions behind the objects again. Thanks for the tip!
BringToFront didn’t worked, however. :slight_smile: