BUG. Can't move the selected points

I have long drew attention to this bug. In Rhino 7, I can’t move the selected points in Shaded mode . If the selected points is on the backface.
There is no problem in the Rhino 5. There is all right.



Yeah, and I do not remember off hand if this is by design or not - let me see what I can find out.
RH-65451 Make pick depth culling not cull wire picked objects that are already selected


1 Like

Thank you for your attention, Pascal.
By the way, it relates to any selected objects.



What move tool are you using? I’ve never seen my mousepointer look like this with the cursor triangles next to it?

Inside Rhino
_DragMode v

This allows me to control better
When I modeling with points in “perspective”

1 Like

This doesn’t seem to be a problem here in my Rhino 7

System info

Rhino 7 SR10 2021-8-24 (Rhino 7, 7.10.21236.11001, Git hash:master @ c1c1a0be2c74a937d5bb85aafdab68e56ed1ab43)
License type: Kommerziell, build 2021-08-24
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-7-2019 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro P4000 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 4-12-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 466.11
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-12-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\martinsiegrist\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\\KeyShot9RhinoPlugin\Rhino 5.0\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.10.21236.11001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.10.21236.11001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.10.21236.11001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.10.21236.11001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.10.21236.11001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

PS: Regarding moving points in a plane, have you ever worked with the gumball?

The problem is in the Shaded mode and other not-transparent modes
No problem in Wireframe Ghosted
On your video is not visible where is a backface side of the surface.\

Of course.
But I do not always use it

Ah, now I understand what you mean with the backface….

But I can still move control points, with and without special drag mode

It is fantastic! Please tell us how you visited the future and downloaded the release with corrections? :wink:

Сlick on the Restore Defaults button. Then write the video and show us.
!!Don’t forget pre-save your settings!!

I think that the transparency value in your mode settings is different from zero. This method has solved the problem with moving but added more serious problems with the displaying other objects in mixed mode in one scene (_SetObjectDisplayMode)

@leex, the only setting which is not default in my shaded view is the individual colors of the surface isocurves.

Hi @pascal
I see what is happening here.
When I work with control points I turn off the “Allow selected objects with control points on”. Since it prevent the flexible modeling.
In transparent modes v7 it works correctly as in the Shaded v5
In the Shaded mode v7 it causes problems. I can’t move the points. Look my first post
In build rhino_en-us_7.10.21244.01001, the problem is not solved.

You could have mentioned your settings change in the first post…

I think if you want to avoid dragging objects accidently you would benefit from activating the Click and drag option “Drag selected objects only”

Hi Martin, I didn’t then know

No, no, you’re wrong

I find it really distracting to read BUG in a topic post when sometimes all that really caused the problem was a change in the settings…

You’re still wrong.
And on the other side, why are you messing and making it very difficult to do the right thing.
I don’t really know why.

Thanks and good luck.

Thank you, all the same.
But right now there’s no way to change settings for move correctly as in v5 (Shaded)

Hi @pascal
For test purposes, I reset all settings to default.
I can move the points but it’s hard to sellect it, the surface is selected too.

If turn off the “Allow selected objects with control points on” then surface does not sellected and it is correct, but I can’t move point.
But I was looking if the surface at large distances from the screen, it leads to drag the point.

May I ask to make it at a short distances from the screen? (without options “Allow selected objects with control points on”)

large distances

Thanks a lot, Pascal!
That problem had been resolved: now the selected objects move correctly.