[BUG] 3D Mouse Camera Tumble

I have a 3Dconnexion SpaceMouse Compact that I’ve been using since October of 2018. My work computer is a MSI gaming laptop with Windows 10 and I lock it away in a cabinet every night for security, so all the peripherals get connected and disconnected each day.

I’m running Rhino 7 and have been suffering from a reoccurring issue where the first time I open Rhino each day and move the 3D mouse, the camera continues to move and just tumbles off into infinity. This happens about 40% of the time I open Rhino and I have to unplug the 3D mouse and plug it back in to reset it to normal.

Is this an issue with Rhino 7, an issue with the 3Dconnexion driver, or an issue with my computer?

The times this happened to me I have had the puck of the device being pressed by other items on my desk - paper work I placed on the device, a pen that pushed it after somehow being wedged between the puck and a nearby larger item.

I haven’t had this happen without anything on or against the device - it has been plugged in to my machine for a very long time.

I’ve also experienced that particular thing as well at my previous job were my desk was cluttered, but in this case my 3D mouse is sitting free and clear of anything nearby. I’ll have to test if this also happens in Rhino 6 or not.

I don’t know if it matters anything, but I have not installed the 3DConnexion driver software.

I use my 3D mouse with quite a few applications so I have to run the driver in order to make adjustments for each app.

1 Like

So I just opened Rhino 7 to get my day started and the 3D mouse is doing the camera tumble thing again. This time instead of unplugging and re-plugging in the 3D mouse, I closed Rhino 7 and re-opened it, and it still tumbles upon using the 3D mouse.

Out of curiosity I then opened Rhino 6 and it’s doing the exact same thing upon trying to use the 3D mouse: the camera just tumbles away infinitely.

At this point it seems like an issue with the 3Dconnexion driver so my next step will be to contact them and see what they say about it.

@Markus , can you help here? Thanks.

I just registered on the 3Dconnexion forums and posted a new topic about this there. It’s in moderation right now, but I will post a link to it once it’s published.

While the 3D mouse was still acting up this morning I tried all the 3D programs I have on my computer. Rhino 6 and 7, Keyshot 10, Zbrush 2021, MeshMixer, Inventer 2022, Houdini 18.5, and UE4.26: the camera continues to move slowly for a few seconds after the mouse has been released in all those programs. In Blender 2.92 it wouldn’t even acknowledged 3D mouse input at all.

After all this testing I then unplugged the 3D mouse and plugged it back in. Lo and behold every single 3D program works totally fine now with the 3D mouse. So this is definitely not a Rhino issue specifically at all.

It surpises me and I think it is confusing that McNeel employees suggest running 3Dconnexion devices without installing 3dconnexion drivers.

@Markus I’ve been in contact with 3Dconnexion support for weeks due to the driver being unable to save my navigation mode (object) and no success so far. It’s a new problem which all of a sudden occured with Rhino 7.

I’m using 3Dconnexion mice too so please no one ever tell me to run 3dconnexion without the driver.

Please McNeel and @Markus much rather fix the drivers so everyone can benefit from proper funcionality.

Thank you

2 Likes

Press shift and click on the 3Dx icon → Run Diagnostics. No need to enable logging, or include the registry. Press "Collect System Information… and send that to me.

Message sent

Hi Derek,

Sorry I couldn’t reply earlier: I have not been in the office the last couple of weeks.
I have looked at the diag you sent: I didn’t spot anything out of the ordinary.

About the tumbling - this may be a device issue.
Some things you may like to try:

Right click the 3Dconnexion tray icon->‘Calibrate’ and see if that helps (My 3D mouse seems to "drift" - 3Dconnexion US)

If the tumbling is still apparent in the applications your device may be broken. You might like to see if the device is sending data by

  • Ensure the 3D application has focus
  • Right clicking the 3Dconnexion try icon->Open 3Dconnexion properties (the application name should be in the title).
  • Selecting the 3DMouse (if you have more than one device listed).
  • Clicking on Advanced Settings.
  • Uncheck ‘Rotations’.
    If the above stops the tumbling, then the device is sending data and may need recalibrating.
    If recalibrating doesn’t help its may be broken.