3Dconnexion SpaceMouse issues

Why is my 3Dconnexion SpaceMouse operating in reverse with Rhino 7 from previous Rhino versions? Left is Right, Forward is Backward and Up is Down. It wouldn’t be a big issue, but there are times I still do some work in the older versions and I have to reset the mouse for them.

The settings of your 3d mouse should let you reverse the direction of each individual axis. Do you have a similar panel?

Yes, but when I set it up for Rhino 7 it reverses all the setting in Rhino 6 and 5.

Yours is a newer model and should be still supported and recognized by the 3DxWare driver, thus it should appear with different settings for Rhino 5, 6 and 7. Couple of years ago I worked with SpaceMouse Compact and it had two separate settings for Rhino 5 and Rhino 6. Not sure if Rhino 7 also adds its own setting on newer 3d connexion devices. Currently, I use SpacePilot (which is a discontinued device) and so I had to make a “hack” with replacing Rhino 7’s driver with the Rhino 5’s one.

What OS are you on and which Space Pilot. I had to get a new one about 2 years or so ago because my old one was around 15 years old and they stopped making drivers for it. As a result I couldn’t set it up to work properly.

Windows 10 with a SpaceMouse Wireless. Works fine with Rhino 5 and 6 but I have to reverse all setting in Rhino 7. The funny thing is I had the WIP 7 version last year and it seemed to worked fine.

1 Like

I use the following “hack” to make Rhino 7 work with my discontinued SpacePilot. Basically I just replace the plug-in in the corresponding folder with an older one for Rhino 6. The only downside of this is that I have to repeat the process after each new update of Rhino 7.

  1. On Windows 10 I already had 3DxWare version 10.3.0 installed.
  2. I opened the following folder: “C:\Program Files\Rhino 7\Plug-ins”.
  3. Then I made a back-up copy of the “3dxrhino.rhp” plug-in and placed it in another folder just in case.
  4. Then I used the following plug-in from Rhino 6.3 and replaced the original Rhino 7 plug-in:
    3dxrhino.rar (130.6 KB)
  5. Then I started Rhino 7 and the 3d connexion plug-in recognized the program as Rhinoceros 5 (SpacePilot has an LCD screen that shows that information).
  6. The SpacePilot required some settings to be made inside Rhino 7, such as “Lock Horizon” etc, just the usual customization that everyone does.

Rhino 6 now seems to be the odd one out in terms of reversing the axes… 5, 7 and 8WIP all behave the same.
All, however, still display the infuriating flippy behaviour when rotating dynamically and moving through the XY plane (direction of rotation freezes when pov is near parallel to the XY plane, the reverses when POV passes through the XY plane). This is a FAULT (!!) and nobody wants to take responsibility for it. Really someone at Mcneel needs to speak to someone at 3dConnexion and together sort this s#it out.
V poor… SMH

@Markus - can you add anything to this?

About the reverse axes:
This is an issue in the initialization of the plug-in when there are no defaults for it in Rhino.
The work around is to create the defaults:

  • With Rhino having keyboard focus right click the 3Dconnexion icon in the taskbar and click ‘Open 3Dconnexion Properties’.
  • Press the ‘Advanced Settings’ button, which opens a new dialog.
  • The dialog title should read ‘Advanced Settings’ Rhinoceros. If it doesn’t, left mouse click into Rhino to give it keyboard focus.
  • Change the ‘Navigation Modes’ setting from ‘Target Camera Mode’ to ‘Object Mode’ and back again. That is all.
  • This needs to be done once for Rhino 5,6,7,8…

Note: If you have checked ‘Reverse’ in the ‘Speed’ tab for all the axes, then ‘Reverse’ will need to be unchecked again.


Have you tried unchecking ‘Lock Horizon’ in the ‘Navigation Modes’ tab of the ‘Advanced Settings’ dialog of the ‘3Dconnexion Properties’ application?

1 Like

This is not working here, doesn’t chanbge anything.
What works for 6 doesn’t work for 5/7/8 and vice versa.
Not a huge deal for me, as the things I need are in 5 and 7/8… :upside_down_face:

This however is a huge deal, as it renders a beautiful bit of kit frustratingly unusable.
Of course I’ve tried the lock horizon options, as well as every possible combination of options I can find, without success. In any case, I want the horizon locked 99.9% of the time… :zipper_mouth_face:

Putting my 2 cents on the pile. Where to begin? Updated video drivers today. I run Vray , Xnurbs for plug-ins. I use V6 with the latest version. I use a space mouse pro. Today during a presentation it decided to not navigate. I checked the settings on the mouse. It is usually on Object mode, but checked on helicopter. I switched it back to Object mode, but it didn’t stick. It reverted back.
When I open it tomorrow I will check it to see if it is working properly. If not, start troubleshooting. Sometimes it is a restart that fixes it. —-Mark

1 Like

Then I suggest you

  1. make a video of the issue,
  2. run C:\Program Files\3Dconnexion\3DxWare\3DxWinCore\3DxDiag\3dxdiag.bat press ‘Collect System Information’ no need to enable logging,
  3. zip up %appdata%\McNeel\Rhinoceros?.0\Plug-ins\3Dconnexion 3D Mouse*

and send it all to me so that I can hopefully see what is happening.


Hi Markus,
thanks for looking.
The vid shows rotating first with a normal mouse, rotating the objects clockwise around the Z axis while ducking above and below the XY plane (note the 3d rotation icon), and then trying to copy the exact same motion with the SpaceMouse (note the 3dConnexxion rotation center icon) always maintaining positive clockwise rotation). As you can see, the view reverses rotation around the Z axis as it nears the XY plane. Every time…

SpinAroundZisReversedThroughXYPlane|video3DxDiag_04032021_004344.zip (7.3 MB) settings-Scheme__Default.zip (721 Bytes)

I can reproduce your issue using your axis setup.

This happens due to the zoom direction settings in ‘Advanced Settings’. The change to ‘Up/Down’ flips the z- and y-axis on the device so that twisting the cap is now a rotation around the devices look-at axis and results in an attempt to topple the world’s z-axis over to the left or right. The lock horizon option inhibits this.
However, depending if the world’s z-axis is straight up/down or not there will be a resultant rotation around that z-axis, the rotation direction being dependent on the direction the z-axis is pointing.

All I can suggest is to either change the zoom direction back to the original ‘Forward/Backward’ direction or use roll instead of yaw to rotate around the world’s z-axis.

1 Like

Yes, I had found these options, but the behaviour I want remains elusive…
As a last ditch I’m going to try meddling with the 3Dx config files to re-map the controls to different axes/translations. Wish me luck…
There are three config files: Rhinoceros 6.xml, Rhino.xml and RhinoFS.xml. Do you know which points to which? R 6 is I hope obvious… :grin:

I’m talking about these lines which iirc relate to which control/input on the device relates to which axis/output in the view. I did this back in the day with my first 3DX device, but the config file was written in a way which disclosed which was whatch.
The variables were input by lines like: Xzy or xZy or YZx etc, which probably still relates in some way to the current variables, but I can’t see which control I am editing (without trial and error).
Anyone know how tro read/edit these? I’ve asked over on the 3DX forum but their response rate is glacial.
Not giving up on this!
:grin: but I’m sure it’s obvious I have no idea about coding… Anyone?

When you hover the 2D mouse over the 3Dconnexion icon in the taskbar a tooltip will list which one is currently being used.


Thanks :+1: