Bouncy Solver Net Floating Away (Probably a very simple problem)

Hi All,

I am running into trouble creating the following:

Basically in my mind this is going to be a combination of the pipe command and Kangaroo’s bouncy solver. However, when I do use the bouncy solver the mesh floats away as below

Also how would one do the netting at the perimeter? I have an idea for the fixings, basically using a cylinder at the points but I am unsure regarding the actual netting. I am sure this is a relatively simple script but I am unsure. I have included the Rhino file and the GH Script of where I currently am. (Note the existing curved surface is just for reference, I will need to fine tune the tensility of the netting)

I am not really sure how to go about using the pipe commaned but I am more familiar with weaverbirds mesh thicken and window frame?

I tried looking at tutorials but still cannot overcome the issue of my mesh floating away
GH (23.2 KB)
GH Net.3dm (4.5 MB)

Thank you!

The main issue is tolerance. In the solver settings, I’d set a higher tolerance to make sure the anchors and mesh vertices pairs are found.

In general I’d create the mesh a little differently.

Instead of a Delaunay mesh I’d simply use the Mesh Surface component. Instead of the Merge component, use Entwine and then Unflatten the output. This way you can retrieve path {0} which represents your mesh.

GH (25.9 KB)

PS: for whatever reason I cannot get Multipipe to work with the mesh edges of the original output mesh. You set the Rhino file tolerance to 0.01 and I don’t know if that is a good idea. Moving the mesh closer to the origin results in a successful Multipipe output. The SubD can be moved back to its original position. Disable the Multipipe component when running the Kangaroo solver…

1 Like

Hi Martin,

Thanks for your prompt response.

I am nearing the intended outcome. However, I have adjusted the position of the points inward and adjusted the tolerance as you stated and ran into a few inconsistencies in the net as below:

Would you have any ideas on how to overcome this? Reason for the adjustment in the position was for the fixings.

I originally was thinking maybe just use the ‘pipe’ component in Rhino but this seems to produce a more optimal outcome.

Thanks for your guidance!

E: Hi Martin, I have solved the above issue. Thank you for your support.

1 Like

You can get the closest anchor point of the refined mesh. In addition to the Mesh Edge goal you can add a separate goal for the naked edges to make them more linear…

GH Net (31.9 KB)

1 Like

To make sure, the naked mesh vertices always match your input points, you could create the mesh with the faces corresponding them: (23.4 KB)

1 Like