Anyone know why this script is not working?

kangaroo

(Lukebralston) #1

Anyone know why this is not working? I am trying to make a tensile canopy for an architectural project and due to the change between kangaroo 1 and 2 the solve component is different and I am not sure how to make it work with this script that was written for kangaroo 1

Thanks,


(David Rutten) #2

Without the file nobody will be able to help you.


(Lukebralston) #3

2.8.18 tensile attempt.gh (13.5 KB)


(David S. Mavrov) #4

It is an old version of Kangaroo. Replace the solver with the new one, replace the spring component with EdgeLenghts, use Anchor for your points.


(David S. Mavrov) #5

Of course it will be a lot easier if you post your initial geometry…


(Lukebralston) #6

what is that final command? after dupln


(Michael Pryor) #7

Happy Square :smiley:

Weaverbirds Mesh From Lines (Weaveback)


(Lukebralston) #8

so I tried the script you supplied and its being difficult…probabalt because im doing something wrong. below is the gh file and the rhino file. Additonally i am trying to mimic a tutorial from a youtube video which is also attached. 2.9 tensile attempt 2.gh (11.8 KB)
tensile attempt 2.9.18.3dm (86.9 KB)
https://www.youtube.com/watch?v=i9pA_YxYkoY&t=1s


(David S. Mavrov) #9

Download Weaverbird for Grasshopper. It just creates a mesh out of the
lines. You can do that any way you want.

На 9.02.2018 г. 21:16 “Lukebralston” mcneel@discoursemail.com написа:


(David S. Mavrov) #10

Ah, I know this video. Give me a bit of time. I will upload a solution.
Anyway, when you make high points like this it is a lot better to use radial mesh instead of linear. If you don’t plan to manufacture this, a linear mesh is good enough for form finding.


(David S. Mavrov) #11

Ok, please in your grasshopper def, interpolate the data for the mesh and points. Upload it here.
Second, all the points in your rhino file are with the same height. In the tutorial the inner points are higher. In order to make tensile membranes you absolutely need double curvature.


(Lukebralston) #12

i internalized the data fromt he mesh and the points, here are the files. thanks for the help 2.9 tensile attempt 2.gh (29.5 KB)
tensile attempt 2.9.18.3dm (96.0 KB)


(David S. Mavrov) #13

Sorry, I think I already made it work with a mesh and points on my own.
Here you go.

Tensile.gh (13.0 KB)


(David S. Mavrov) #14

And this is how you do it if you want to actually manufacture it. Unfortunately this can’t be done in Grasshopper… or at least not in an easy way.

Cones.3dm (866.5 KB)


(Lukebralston) #15

thank you! um so i keep having this issue of not having the edge lengths object, and i downloaded a component called m+edge lengths because if was all i could find and it isnt working, could you send me your edge lenths file by chance?


(David S. Mavrov) #16

Just download the last version of Kangaroo. Or the verdion it shows you in
the error. I think it is the last.

На 10.02.2018 г. 0:58 “Lukebralston” mcneel@discoursemail.com написа:


(Lukebralston) #17

ok so the script is working for what i want. There is one issue. So I run the script and then move the points in the center of the mesh up and down to form the mesh canopy for the design. I can move the points up and down but if I move one or the other too far the weaverbird component at the end fails. is there a way to prevent this? thanks Tensile 2.10.ghx (116.7 KB)


(David S. Mavrov) #18

Just find another way to construct the mesh. The weaverbird component was
just a fast way to show you a result. It is known to have issues with
certain geometries. In other words the behaviour you observe.

На 10.02.2018 г. 22:44 “Lukebralston” mcneel@discoursemail.com написа:


(David S. Mavrov) #19

You can use the points of the result from the solver and for example
delunoy the mesh. Then introduce the outer perimeter of your original input
geometry as a joined polyline and limit the delunoy triangulation within
your desired geometry. That’s one example. I am sure there are more.

На 10.02.2018 г. 22:49 “David Mavrov” davidsmavrov@gmail.com написа:


(David S. Mavrov) #20

I think if you just connect a simple mesh component to the geometry output
it should do the trick. I don’t have access to a computer right now. And I
haven’t played with kangaroo for a while.

На 10.02.2018 г. 22:52 “David Mavrov” davidsmavrov@gmail.com написа: