Multi-pipe with multiple radii issue


I’m trying essentially to create a multi-pipe with multiple pipe radii and a few extra constraints (similar to what has been discussed in this thread: Different pipe sizes in MultiPipe - Grasshopper - #3 by DanielPiker). However, when the kangaroo solver is run I end up with a mesh that’s being sucked in (see pink mesh) as opposed to a smooth radius between constrained edges (see green curves). I’ve tried changing the parameters for my goals, but regardless the solver comes up with a similar solution.

Any suggestions for how the script could be changed to achieve an entirely concave curvature would be greatly appreciated.

Thanks a lot! (21.2 KB)

Hi @lappel

For fairing the triangulated mesh without it getting sucked in, you can use SolidPtCollide to keep the points exterior to the original volume.
I’ve also shown here how you can set the different radii in MultiPipe and get NURBS with circular ends: (35.4 KB)

this is exactly what I needed! Thank you very very much

1 Like

hi @DanielPiker ,
have you any idea how to fixe the radius of the pipe size? when you use MultiPipe?
I used (35.4 KB), and when I change the Pipe Size, MultiPipe change the size with a factor, and i cannot keep the original radius.
Do you have any idea how to solve this issue?

I put some image where i Comparate the Kangaroo method and the MultiPipe Method:

the goal is to keep a radius fixed.
If someone have suggestions for how to script that, i will be happy :slight_smile:

Thanks a lot!

tripod_table_base2 Edited (38.8 KB)

Just a try.


tripod_table_base2 Edited (47.8 KB)

And you can use my Offset Loop Cut to make rounded edge solid.


Thank you for your help!
This way help me. I didn’t know Flexibility.

Unfortunatly, with SubD Fuse, i cannot ajust the curvature between the two pipe like the MultiPipe Method and the Kangaroo Method. I want to have the hand on this parameter.
But I will continue to explore more.

Thank a lot for your help.


Hi @Léopold1

Because of the way the radius interpolation is currently working, it seems that for some small curve networks the radii at the SizePoints inputs are affecting each other. This shouldn’t be happening, and I’ll try and figure out why it is.
However, in the mean time, I found that extending the curves by a segment fixes the issue for this case.
tripod_table_base2 (2).gh (33.5 KB)

1 Like

Hi @DanielPiker,
I understand what is the issue. Thank a lot for your time.
If you find a solution, keep me in touch. it will be a pleasure to understand how that work.

Thank you for your script!
I will try to apply it on my specific case.