Boolean union succesfull - undo - again boolean union - failed


this is a really strange bug. i do boolean union it works. then i hit undo and do the very same thing again and it fails…

It is very difficult to diagnose this type of problem without a .3dm file with the geometry. The file only needs to have the geometry is involved with the problem. You can upload a file by dragging it to where you type your post, or by using the vertical arrow above where you type. Also needed is which version of Rhino you are using. Help > About Rhinoceros and look in lower right of the window which appears.

1 Like

booleanundofail.3dm (1.6 MB)

select all on the current layer --> boolean union --> it will succed --> undo --> boolean union again --> fail

I could not duplicate the same problem using Version 6 SR24 (6.24.20064.12211, 3/4/2020). I did have BooleanUnion fail when I selected all the objects but work when I selected only a portion of the objects. After Undo BooleanUnion worked each time for me.

The objects are 33 million units from the world origin. Rhino sometimes has problems with objects that far from the world origin. Try moving the objects closer to the world origin and see if the problem continues to occur.

I know its far from origin and i acknowledge there are sometimes problems with this. but what i found really strange is that it worked fine but undo and same operation yielded different results which is not something i can understand… i will take a video and post it

Hello - I believe this fails depending on selection order - I’ve isolated a pair of objects that works one way and not the other, I’ll check with the developer, if it does not work as expected in V7.
It seems to be fixed in V7.


1 Like