Boltgen stopped working, no bolt heads supplied no more

The title says it all! Boltgen says error: “No head data available, making threads only”. And the website is out off service!
So anyone knows how to get the heads back? Have tried reinstall and unblock, but nothing works! Is there anyone that have an older version still in their library?
Any tip would be great…

Here’s something I found on my computer. Is this it? Will it do you any good?

BoltGen.rhp (428 KB)

Also, if I recall, there is a checkbox to use if you don’t want heads. Does that ring a bell?

@AlW And thanks for reply, but it did not work… Tried to install in Rhino6 also but no go but then its another error (see screendump)
It dont finish the work, dont know what is going on here, tried to make a bolt with head… uninstalled, unblocked etc… going crazy here and its late, no dinner…
And I know you could make it w/o heads but that´s not it, when I get that error “No head data available, making threads only”

There’s a version 1.85, written in Python for Rhino version 5,6,7 available for download on Food4Rhino.

Yeah I know it was that I started with.

Oh, OK. Just curious: was it a relatively recent download that didn’t do heads “out of the box”, or did you run it successfully for some period and then it just stopped doing heads?

Or did you have a running version that stopped working and you downloaded a fresh copy from F4R and it didn’t work from the start?

fwiw- I never make bolts since this came out

It was an installed version that I have had for sometime that just stopped working. I then tried to download it again and also tried an older version but same problem. Strange thing is that at my workstation at home it dont have the same behavior. Will try to figure out what the difference is…
Thanks for your help though!

Hi Kyle Thanks for the tip, I know about mcmaster but I think it so much simpler to make a bolt inside Rhino…

to each their own…

I have a clip art file I’ve built over the years with parts in it (including fasteners) that I simply drag and drop onto rhino when I need them… I personally have a moral opposition to building stuff twice unless necessary.


I may have a solution. Do you work in millimeter units?

1 Like

Hi Dan yes I work in mm!

Try this link:

I use the same BoltGen 1.77 Plug-in on both Rhino 5 and Rhino 7 with no issues.

Rhino 5:

Rhino 7:


BoltGen.rhp (468 KB)

I’m pretty sure Per has the solution he needs. :wink:

Please share, what is the solution Per has :wink: :wink: and may we all benefit from it since BoltGen appears to be dead?

Would you still be interested if there was a cost involved?

Apparently the answer to the second part of my query is “no.”

And I guess the answer to my question is “No” as well

It still works fine on my machines (1.85) - so the question is really “what changed on some people’s machines to break Boltgen?” Windows update maybe? New plugin added?

1 Like

By “dead” I meant unsupported, defunct; it still works but it’s an orphan. Sorry I wasn’t more clear.