Boltgen has stopped working

Boltgen has recently stopped working on my V7 version of Rhino. After selecting the various options, when sent off to creat the item it freezes Rhino with the message “Boltgen loading” in the Command History. The only way to get out of this state is to use the Mac “Force Quite Applications”.

I’m assuming it’s just me as I could find no resent posts. If so, how would I sort this, or should I just wait for the next update of Rhino?

While I find Boltgen super useful, over the past year it seems to have been slowing down between each selection page (Metric/Imperial, head style, length etc) and the option to tick select which items are created (screw, nut, thread cutter) never seems to work with more than on item selected, any chance it could be given a bit of a tweak?

Hello - I would get in touch with the developer of BoltGen.

-Pascal

Thanks for the response.

@cf53

FWIW, I’ve tested BoltGen (and the thread cutter scaler command) on the latest Mac Rhino V7.

Works as it always has. Granted the checkboxes for what you want built have always been a bit obfuscated in what gets created, but that’s always been that way. Essentially, if you want a thread cutter, you have to so that as a separate run of the command.

For sizes that don’t land within the predefined list, you can always run the “special” at the top of the menu and directly specify the diameter and thread pitch. Bear in mind there are combinations you can do with that that simply won’t work (usually due to the inset of the pitch crossing the centerline of the diameter axis).

But FWIW, it seems to be working fine on my install. Running Big Sur 13.x on a 2010 classic Mac Pro.

@LewnWorx

Thanks for giving it a go. I assumed it was more likely to be something specific to me rather than Boltgen, seeing as no one else had spotted it.

I am on Monterey, so possibly that.

@cf53

Could be. I’m parked at 11.2.3 as at the time OpenCore had serious issues with anything past that (race conditions and other nasties at startup). It’s since been fixed but I haven’t had the time to rebuild open core to allow me to go past that, and for now, that’s fine as I’m able to do what I need to do.

@LewnWorx

Are you the creator of Boltgen? If so, thanks for having made it available.

Nope, just been using it for years. I think Ray McKaig either wrote it or is the current keeper of the project. It’s been immensely useful.

On a similar note, are you aware you can get ANYTHING in McMaster Carr’s catalog in STEP format?

I’ve got libraries of their parts that have all been downloaded and put into named blocks. I haven’t done the entire catalog (that’d take years) but mostly stuff I commonly use like bearing pins, dowels, oddball bolts and knobs, etc. It’s a great resource.

@LewnWorx

I was aware of McMaster Carr, and have used bits from them. A couple of years ago it seemed to stop working for me, I’m in the UK and my guess was they now only allow downloads to certain regions.

In truth I should stop using fasteners (current drawing has 184!) in drawings, my Mac noticeably slows down when scrolling the screen about. I should probably just use the heads if I need a quick render of the final item.

I look at Blocks every now and again, and just get confused. I tend to just remember which drawing had an item I need, and cut and past it, bit naff, but it works.

Well if you’re using that many fasteners in a drawing, you definitely need to be using blocks.

Every time you copy past, you’re creating additional duplicate geometry in the model, which chews up a bunch of ram. By creating a block for each fastener type, you only take the hit once for the geometry and a far less amount of overhead for the clones. I’d bet you’d find the machine far more responsive as a result.

Also, if you don’t need the threads, model the bolts via bolt gen without them, as probably 90% of the overhead for a single bolt is in the threads. In my case, I need them, as most of my work is being used for FDM fabricated plastics, so they have to be there. But for render / illustration purposes, if they aren’t visible, you could lose them, and by going treadless still have the actual hole detail and whatnot if you need to show the part sans fasteners.

@LewnWorx

It’s some time back since I first tried Blocks, but if I’m remembering correctly I found it reduced the file size, but didn’t help much with the gradual increased jerkiness of the display as additional instances are added. The other problem I’d had was after creating some more complex parts on different lays, I then turned them into a Block instance and started putting them on different layers within groups of layers (different parts in an assembly), only to find out they still had a connection with the original layers they had been created on.

I did revisit them a month ago, intending to create a file of parts (as you mentioned) that could be called into future models, I’m obviously missing something, it didn’t seem to work as I assumed it would. So, if at first you don’t succeed, give up. Copying parts from old drawings isn’t elegant, but it always works.

I’ve used the thread cutter in Boltgen in the past to create threads in SLS/MJF parts, but some times found them a bit iffy, so I tend to either use Helicoil inserts (used for thread repairs) or pocketed nuts. I’ve recently tried some self tappers specifically designed for use with plastics on a batch of 3D prints delivered just before Christmas, that worked well, and I’ll definitely be using those again.

Thanks for the guidance.

@LewnWorx

I was just going to go and cull all the screws in that drawing so they only had heads, but first I thought I’d look at Blocks again, and the part I created a month ago worked first time.

I clearly have no idea what I’m doing!

For FDM applications, it varies. If it’s not super structurally intensive, I’ll either model in threads, or in some cases just make the hole diam smaller by 0.5-0.8 (depending on screw size) and go that route. For small stuff (like 2.5-4mm) this works fairly well, just ensure you either use enough perimeters or model in a modifier to locally add perimeters in the area and that’s pretty decent.

For more robust stuff I tend to use heat set inserts, and these work ridiculously well, as the plastic will break before the inserts pull out. For example I’ve got some parts with 1/4" inserts that are holding 50# loads. You need to get the right flavor of em as the common (looks sorta like dual helical patterns that don’t have a bottom smaller ridge) are a PITA to get inserted straight.

Here’s an example of the wrong kind:

You want this flavor that has the inset ridge at the bottom.

McMaster Carr has em, and you can also get em on Amazon, just make sure for whatever size you get ones with he inset ridge.

I put em in with a set of brass tools for this purpose that replace the tip on my soldering station. Works great.

Best part, is unlike the self tappers, you can unbolt and reboot them without tearing up the plastic. Just thought.

@LewnWorx

I’ve contemplated that type of insert, but worried about getting one in skew-whiff and buggering the print. I get prints done outside, so it’s not just a matter of printing another one overnight.

Most of what I do goes into radio studios. It’s made and installed, five years later they do a refit, the item is ripped out and thrown in a skip! Rarely does anything get opened or maintained.

I’ve had a look at bits for my iron (JBC) and they do some staking bits that look like they may work, so I may give them a go in the future.

@LewnWorx

Boltgen works again!

Had an update for Rhino this morning Version 7 (7.14.21362.13002, 2021-12-28) and now it works again. Some how it had become corrupted in the previous version?

There has been problems with boltgen for windows also Boltgen stopped working, no bolt heads supplied no more
And there is also people having problems with it at food4rhino BoltGen with Manuals and help for Rhinoceros (Windows and MAC) | Food4Rhino
(read the comments section)
so your not alone!, doesn’t help I know…