BoltGen: Rhino plugin's for Mac!

Hi Jason.
I responded to denbutler about the new python BoltGen. He should have a BoltGen menu drop-down to execute the programs. I haven’t received a message from you (wrong Email address?), but my contact information is: ray.mcvan@comcast.net

Send me an email and I will send you the install package for Mac. Also, I can zip the individual items and send them separately if you want to play with setting up an installer. I don’t seem to be having much success. I do know that you can unzip the installer and extract the individual files from it, but there is a certain way to accomplish it that I do not know. I wish Mac had followed standard folder protocol.

It is possible that BoltGen did install for Paul Noone, but the menus and toolbars did not get activated. If so, typing _BoltGen on the command line should launch it. _BoltGenHelp may also work, as well as _CopyBoltToSurface. Assuming that is the case, then the BoltGen_py.rui file needs to get installed as well (other than dragging it onto Rhino like in Windows, I’m not sure how it can be accomplished). Also I understand that the Plug-in function for Rhino (in options) has not been implemented in Mac Rhino 5 yet, but will be included for Rhino 6.

Regards, Ray

Jeff,
Please see response to jason. I will send the installer to you also. By the way, BoltGenMac was a mistake. The corrected installer is BoltGen_py.macrhi.
ray.mcvan@comcast.net

Any help is much appreciated.
Regards, Ray McKaig

Hi RayM, Typing BoltGen in the command line did not work, I just got the message Unknown command BoltGen

Thanks

Paul

Ray,

The first email went to your mcvanaero account that you had posted on food4rhino.

I have resent the request email. Sending the installer as well as the individual items would be helpful in troubleshooting these issues.

Again, I would like to thank you for taking the time to port plugin to the Mac. This is a really a great plugin.

Jason

Hi Jason.

I’m sorry, the email address had to be changed because of hackers and got broken. I just fixed it and … goodness, 46 messages in it !!! ray@mcvanaero.com is correct now.

I want to thank you for taking the trouble to help. I really appreciate your efforts.

Here is the .macrhi install file.

Hierarchy for the files:

            BoltGen_py.macrhi  (zipped install file)

                            BoltGen_py.rhp (folder)

                                            BoltGen_py.rhp  (program)

                                            BoltGen_py.rui   (menu and toolbars)

                                            HowToUseBoltGen  (folder)

                                                            languages.pdf  (several files for languages)

                                                            BoltType.pdf  (for illustration of creation bolt heads)

Also included is a zip file of the parts without the .macrhi final zip rename. If this is a problem, I am also including the .rhp and .rui separately without the folder of help files.

Regards,

Ray McKaig

McVan Aerospace, LLC

(360) 597-4155

http://www.mcvanaero.com www.mcvanaero.com

BoltGen_py.macrhi (1.07 MB)

BoltGen_py.zip (1.07 MB)

BoltGen_py.rhp (245 KB)

BoltGen_py.rui (153 KB)

1 Like

Running the installer did appear to install the plugin. Rhino stated BoltGen was installed and needed restarted.

When I look into the installed location.
~/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/
BoltGen_py.rhp is the only installed file
Missing was the BoltGen_py.macrhi file and the HowToUseBoltGen folder.

Mac Rhino does not have a tools\options\plugins menu option, because the plugin manager has not been developed yet for MacRhino. I hear that is not been slated until the V6 release.

I have manually installed these files make sure all the files were in the “MacPlugins” Directory.
I understand the the .rhp, .rui, and the Help folder need to reside in the same directory.
As stated in http://developer.rhino3d.com/guides/rhinocommon/plugin-installers-mac/
Putting the whole folder BoltGen_py in the MacPlugins folder should allow it to load.
But I am getting the same error no matter what I do.

Running the installer or manually installing the files give me this error when I restart the program.
I have tried this on WIP and standard release with the same result.

Trying to drap and drop these files on the Rhino window gives me this error.
This post is almost year old so I don’t know if it is still relevant but maybe something to read.


I am also wondering if the .rui file is even supported.

This is what I have done so far, but with Rhino refusing to load the plugin, I not sure how to test any further.
Maybe @dan could give some insight on the issues we are encountering.

I’m looking into this now with @RayM’s help. Ray will need to convert those rui files, unfortunately, but we still need to figure out what is going wrong with the packaging/folder structure of the PythonPlugin.

I’ll probably need to enlist @pascal’s help as he’s the one who has managed to get this working in the past.

1 Like

Hi all - When I tested this many moons ago, I tested a py file being installed, via a sort of painful manual ‘rhi’ making process outlined in Dan’s link - that much worked, at the time, as I recall - as far as other files to be installed from the renamed zip goes, I really don’t know what is expected to work.
-Pascal

I have found and fixed the bug (MR-3135) that is causing BoltGen to fail to load. I’ll get this fix in the next RhinoWIP.

CC: @RayM

1 Like

Hi Dan, will there be an upgrade for version 5.3.2 (not WIP)? I no longer have a WIP version

Thanks

Paul

There will indeed be a 5.4 update. We don’t have a timeline yet for this. In the meantime, if you are a license holder of 5.3.2, you are always free to use the RhinoWIP.

BoltGen should load in the latest RhinoWIP (5E140w). Please give it a try.

1 Like

Thank you Dan, I will download a copy of WIP later this evening

Paul

Just a quick update. I downloaded the latest version or RhinoWIP and managed to install the BoltGen py.macrhi file. To my relief it worked. I will be using this plugin quite a lot in the future and will let you know if I come across any issues as I go.

Thank you to everyone who helped to get this plugin working and thank you Ray for taking the time to write it.

Cheers

Paul

3 Likes

Also confirmed! Really great to have this plugin added to my toolbox. Works Beautifully.

BoltGen: Confirmed and works
ThreadCutterScaler: Confirmed and works
CopyBoltToSurface: Confirmed and works

@dan ToolBars are not working yet, but curious how they will even work. Mac rhino does not supports floating toolbars, so the introduction of a plugin toolbar is curious. How will they even load within the constructs of the GUI?
Maybe I don’t have grasp on the subject, and there is already something in place for custom pallets…

As I understand it, custom modified pallets are constructed under the Command Editor. Only one pallets is loaded (displayed) at a time based on the selection made under “Themes” under Preferences.

Just how are Plug-in Pallets displayed once the .rui file has been converted to a .plist file and incorporated with the plug in? I am only asking this, for any PC Plugin Developers with limited Mac experience can fully port a plugin to the mac and fully be supported in the way for which it had been written.
I see how to do it within you developers doc, but have never seen how it has actually been implemented in other plugins.

With all this said, The plugin works great, I can make my own buttons within my already modified tool pallet if I really have to have a button to push. It would just be great to have a floating toolbar, ribbon, or tab. that would load with each plugin if the developer intended it to have one.

The situation right now with tool palettes is not ideal. We have a lot of work to do to make this work better for the third-party developer.

In general, with RhinoCommon plugins authored in C# - as you alluded - the developer has to convert the .rui to a .plist, add the .plist to the project, and then tell Rhino to load the tool palette. Even this - though it works - could and should be improved.

The problem with plugins generated by the RhinoScriptCompiler (on Windows), as BoltGen was, is that they are basically a long string that constitutes the python commands, wrapped in a default plugin wrapper. So, at the moment, there is no way to tell Rhino for Mac what .plist to load. Even on Windows, I’m not seeing consistent behavior with Rhino for Windows loading the .rui file…if you know how to get this to work, please let me know. I’m just about to hunt this stuff down in code.

One way we’re considering moving would be to “just load the .rui or .plist that shares the name as the plugin.rhp” by default. This might get around the problem, but we’re still considering it.

Dan,
I have had the problem with .rui files being ignored when installing an updated copy of BoltGen. It looks like Rhino somehow remembers if a .rui file has been loaded previously and ignores the new installed .rui reference. To get around this, I had to delete previous installs (in Users folder, and possibly in Programs/Common also), then the .rui file installed correctly and the drop-down menu items and toolbars showed up. Hope this helps.

I’d like to express my thanks for porting BoltGen to the Mac, it really is appreciated and my modelling life has just got a lot easier.

2 Likes

This is what bolt gen create for me, tried a few combinations

still finding it buggy, any one else. love the plugin but struggling to use it on Mac

@RayM