Black Viewport after update

Hi, I updated my Rhino v6 and Windows 10 this morning and ever since then all my viewports have been black. I tried turning off hardware acceleration, which kind of fixed the problem- but then even drawing a simple line in a blank file took 5 minutes.

I am running Rhino on Parallels for mac and everything was working perfectly this morning.

Attached is my system info

Rhino 6 SR27 2020-6-24 (Rhino 6, 6.27.20176.05001, Git hash:master @ ba2c30de00be5a8b210bc297715204e941911799)
License type: Educational, build 2020-06-24
License details: Cloud Zoo. In use by: Graham Drennan ()

Windows 10.0 SR0.0 or greater (Physical RAM: 8Gb)
Machine name: GRAHAMDRENN1C8E

Non-hybrid graphics.
Primary display and OpenGL: Parallels Display Adapter (WDDM) (Unknown) Memory: 1GB, Driver date: 6-15-2018 (M-D-Y). OpenGL Ver: 2.1 ATI-1.68.25

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Parallels and ATI Technologies Inc.
Render version: 2.1
Shading Language: 1.20
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.27.20176.5001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.27.20176.5001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.27.20176.5001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.27.20176.5001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

parallels is not a supported operating system. This is why. Bootcamp is the only supported way to run windows on a mac.

you may need to go back to 6.26 if it worked there.

I have the exact same problem as Ddrennan, but how do you go back to 6.26?
Thanks,

e-mail tech@mcneel.com and they can get you a link.

1 Like

Thank you! I emailed tech@mcneel.com and they sent me version 6.28- which fixed the problem immediately after I installed it.

1 Like