Background bitmap surprisingly pixelised

display
bitmap

#1

Hello everyone
I have recently bought myself a new computer.
I am working on a file with a background bitmap of large size (9000x6400pixels)
Thing is the image used to display perfectly on my old laptop (16000x16000pixels is the maximum texture size indicated) and on my new laptop its quality is greatly reduced when displayed on rhino. (I still have 16000x16000pixels max though)
I don’t understand, every spec of my new laptop is better than the old one, and the rhino parameters seem to be the same one on both.
Especially the graphic card, I have an Nvidia Geforce again, and it is just better.
I’ve configured the graphic card to be used by rhino on both laptops… and still, the new one just displays the image terribly.
There’s just one thing : on the old laptop, the total video memory was 1024Mb, and on the new one it’s 64Mb, but I also don’t understand that, cause once again, my new graphic card looks just better than the old one for every spec.
Please help with that… any input…


(Nathan 'jesterKing' Letwory) #2

That generally means you haven’t yet installed the proper drivers for your card, nor the latest. Please get the latest NVidia GeForce drivers, install them, and see if things improve.

/Nathan


#3

Thanks a lot !
Well I did, that, I even just reinstalled it to make sure…doesn’t work. I guess you could be right though, because rhino can’t detect the driver’s date and version (I get NA instead), so there has to be something wrong there…

I’ve noticed that in the wireframe display settings, turning the pipeline display assignment from OpenGL to windows solves the problem… (on the other hand it generates a lot of lagging when zooming in or out).
There must be a chance my OpenGl isn’t up to date… tell me more about it if you have any idea, but in the mean time i’ll check about my openGL version


#4

Usually laptops have intel chips with builtin graphics, which they use by default in order to reduce power consumption. If they also have a higher performance graphic card, which many higher performing laptops include, the high performance card needs to be specifically enabled. Have you checked in your documentation how to do this?


#5

well I’ve told my Nvidia to work for rhino, so that when rhino is on, nvidia tells me that is active for rhino… that’s what you mean right ?
I had done it for the old one, and did it for this one too.
tx


#6

Could be the power setting though as Al said, so make sure it is set to performance.

Do you see the same effect when drag and dropping an image onto the Rhino workspace as a picture frame?


#7

Well when I add it as a picture frame, it isn’t pixelised, but it is blurred, and when I switch the display pipeline assignment, it does get fixed, and it does start lagging a lot…
I’ve checked the power setting, it’s all good.
Thanks


(John Brock) #8

It’s also possible that you can improve for correct this with the Texture Size seeing in Rhino.
Options > Rendering
Try a larger or smaller setting and see if that has an effect on the display.

From the Help file:
Texture size
When a procedural texture is displayed in the viewport, it is created as a bitmap on the disk. This setting determines the size of the image on the disk. Using larger textures can improve the viewport display, but may slow down certain operations.


#9

Thanks a lot
Doesn’t work, it doesn’t change anything to the background bitmap display…
I don’t know… I’ve updated my graphic card driver thrice… still nothing changes