Back Again with this missing text problem

I’ve posted this several times and got no answers. When choosing a template the text is not visible. I eventually came to believe that is was related to the Dark theme I had created by changing color in the advanced options. That somehow the text color in this window was changed to the background color and was therefore invisible. Thought it only affected RH7, when I began sharing the RUI file between my RH6 & 7, the problem then afflicted both.

I removed both programs, all their registry keys according to the McNeel wiki, and all other McNeel folders, and references to McNeel. I then reinstalled RH7.8. The problem persists. This is driving me insane.
I looked at Advanced setting filtering for modified only, and nothing seem amiss.

Please, if anyone can help.


Anyone? Thoughts? suggestions?

Do you have other dark-themed apps, particularly Windows itself? If you obliterated all Rhino-related material before installing (kind of a big if, given that the wiki doesn’t strike me as an up to the minute resource) then the setting would be coming from outside, presumably a Windows setting.

I tried running procmon to see if there were any clues from registry access during the Rhino startup but unfortunately there are over 50k events to wade through. You probably need to ask one of the Rhino devs directly where the setting comes from.

Thanks for the response. I don’t know how to address this with McNeel. I’ll put together the info at some point and send an email. Odd that the identical dark advanced settings work fine on the desktop. Both machines have nVidia VC. Though the laptop is a newer RTX2070.

@brian - do you have an idea about this?


That’s weird indeed. @Trav do you have any idea where Rhino gets the colors for the template files in the splash screen?

@brian its hard coded to black. I wonder if there’s a font scaling issue at play here. I’ve seen something similar in the past with the Taiwan language pack. @CalypsoArt what size do you have text set to display at in Windows and what language pack is Windows currently set to?

I haven’t got a chance to look, but I do believe that I changed the font scaling in windows at one time.

Nope. Scaling is as recommended. Region is US as is the language pack.

I’ve never solved this problem. Turns out I’m not the only one. Just came across this tutorial video and the creator seems to haave the same problem. At the 00:14 mark.

Yeah, but you are not comparing like with like. His Rhino is not your Rhino: