Autosave Turned Off?

Is it possible that an update turned autosave off? I don’t seem to have any autosave files for the past couple months.

I just worked on a passion project all weekend, 2 hours here, 3 hours there…and the new version of VSR just crashed. 10 hours of work down the drain. I love the open nature of Rhino, and all the plugins that are available, but this is a stupid problem. MSFT Word figured this out almost a decade ago.

RhinoGold taught me to set autosave to every 5 minutes, somehow it got turned off, and I am livid.

I never count on the autosaves. Here is what I teach my class to do to avoid any loss of data:

  1. Save the file every 30 minutes with 'file --> ‘incremental save’
  2. When you finish for the day, just keep the last 3 files if you are short on space
  3. While you are working, if there is a Rhino or OS crash / power failure / surge / someone trips on your power cord … any open file can be get totally corrupted. Not a problem; just re-open the previous version and you have only lost 29 minutes of work.

The class loves this technique and they now do it for all projects, even when they are using Photoshop or Illustrator.

Have you checked in the settings?
It is normal not to find autosave files for the past couple months. The are deleted upon successful closing of the application.

Autosave was definitely turned off in the settings. The last autosave file I have was from November.

Hi Eric- we have had some reports in some cases that suggest a plug-in may be changing options in some cases- are you running any non-default plug-ins?


Hmmm. TSplines was one of the suspects… not sure how to test this, but you can add the attached script to your startup process - it will check Autosave every time Rhino starts and warn you if it is turned off. Download the zip file, unzip the rvb file and save it someplace- then drag and drop the rvb file onto Rhino - after that it should just load every time Rhino starts. You can also run it as a command alias - AutosaveChecker. (394 Bytes)