Autosave doesn't work


#1

Rhino interrupts what I’m doing every ten minutes to waste five seconds of my life flashing “Autosaving”.

I’ve given the Autosave file a distinctive name. I know where to look for it:
C:\Users\Bathsheba\AppData\Roaming\McNeel\Rhinoceros\5.0\AutoSave\RhinoAutosave fooo.3dm

But when Rhino crashes, and I look in that directory, the file is three days old. It is never current. I don’t know what Rhino’s doing during that infinite number of five-second interruptions, but it’s not saving any 3DM file anywhere on this computer. I’ve looked.

The Autosave feature is annoying (why can it not save when I’m idle instead of when I’ve just input a command?!) and it doesn’t work. It has never worked for me in Rhino 5.

Can this be fixed? Like, right away?


#2

When you open Rhino again (not by opening a file, just opening an empty instance of rhino), does it tell you that rhino shut down unexpectedly, and this is the last autosaved version of the file? That’s the behavior I see here.


#3

Don’t know, I’ll check next time it crashes.

This doesn’t have to do with my question, which is where is my autosave file, and why is it not where Rhino says it is?


#4

That I cannot answer. I was just curious because if it did do that, then it might indicate that the autosave file does exist, it just isn’t where you’ve asked it to be. If it doesn’t do that, then that’s a different issue, probably. I can’t really help with either, just making suggestions to help track down the problem more accurately.


#5

Isn’t the unexpected-shutdown message related to the CrashDump file rather than the autosaves? I do see crashdumps when Rhino dies, but I don’t like to rely on them because they’re often already unstable.

I’m just looking for autosave to work as advertised.


#6

I don’t know if this helps…

If the active model is named, the Autosave file will be placed in the default Autosave folder and be named as follows:

<auto save folder>\\<file name>_RhinoAutoSave(<thread_id>).3dm

If the active model is not named, autosave file is written to the default Autosave file.

–Mitch


#7

But I’m really telling you that this doesn’t work. Files of both name types are in that folder, but they’re saved rarely and are almost never current. This is what my Autosave folder looks like right now:

You can see it saved one a few days ago, but the rest are old. Notice how they’re spaced out: May 12, May 7, May 2. That’s what I usually see. I use Rhino every weekday. About six hours today, and despite countless “Autosave completed successfully” interruptions not a single autosave for today is present.


#8

OK, that does seem very odd then… I never use autosave here, I will try turning it on here and see if it is working.
Just grasping at straws here, if you reset the autosave directory to some other place where you know you can write files like “my documents” - does that work? It seems odd that Rhino is going through the motions of autosaving a file and nothing is showing up - it’s like it’s being denied permission to do so…
–Mitch


#9

I just checked and I can confirm something is not ok.
My last autosave file was dated 9th june 2013… that can’t be

If I run _Autosave manually it seem to work ok.

thx, Tobias


(Wim Dekeyser) #10

It doesn’t make sense starting to look for old autosaves around the disk.
If Rhino is closed in the normal way, the autosave for that file is deleted.
AutoSave works fine here…


#11

I looked for autosave files with Rhino open

thx, Tobias

EDIT: It does actually work with a saved file. I don’t see autosaves for Untitled files


(Brian Gillespie) #12

Autosave and crash recovery are different tools, actually. The moment Rhino crashes, it works hard to save your geometry to the crash dump file. I don’t think it saves any plugin data, though, which may be what you mean by corrupted.

Wim is right about Autosave cleaning up after itself. When Rhino closes normally, the Autosave files are deleted. The ones in your folder are likely from the times Rhino crashed. Does that help explain the lack of files?


#13

It does explain why there aren’t 10,000 files after 10,000 autosaves…
but it doesn’t explain why there is almost never a current autosave.

I’ve tried changing the directory. But you can see Rhino is able to write files to the one I’m using, because every several days it does.


(Pascal Golay) #14

You’ll want to look in this directory while Rhino is still open to see if the current session is writing an autosave file. Looking later, after the current file has been closed, will not tell you anything because the autosave file is removed when a file is successfully closed. Any autosave files still lurking in this directory are there because at some point Rhino crashed and did not clean up the autosave- that is the intended behavior anyway. However, Rhino should, after a crash, offer to open the autosave and let you save it properly.

So, all that said, after a crash, if you do not see a current autosave file, and you did dont get the offer, on opening Rhino to open the autosave file, which is what I understand, then that seems wrong to me… I guess the fallback is to look for the 3dmbak file which may get you something useful if a little older than you like, but I guess I’d still like to know what’s going on with the Crash/Autosave combination.

You might try the Autosave command- and verify in the Autosave directory that it is indeed written, as a start.

-Pascal


#15

I do look in the directory while Rhino is open.
The screenshot I took was while Rhino was open with a named file.

What typically happens is not that Rhino actually crashes, but that it hangs and I kill the process. After that I want there to be an autosave file, but there never is. If Rhino is cleaning up those files on process kill, that’s not useful behavior.


#16

This still doesn’t work for me: Autosave interrupts my work on schedule, but it doesn’t actually save a file. It works if I run it from the command line, but not when it runs automatically.

I see that I’m not the only person to have this problem.

Can this be fixed please?

Thank you.


#17

i have seen this problem too.

I usually have more than one rhino open, and i do see autosave files getting written for each open file.
and i do often sucessfully recover them if i need

but sometimes, i am sure to have seen a recent autosave process happening in a session, and if it then crashes shortly after i look and there is no autosave file.

also often after a crash, there is an autosave there, but upon restarting rhino, i get no autosave-open dialogue. the file however remains in the autosve folder and i can still copy it from there.


(Pascal Golay) #18

@JohnM, any ideas here as to what might be happening?

thanks,

-Pascal


#19

YOU KNOW WHAT? YOU MY FRIEND, HAVE SAVED MY LIFE. My rhino file crashed and there was not a 3dbak file in my folder and I have an assignment due TOMORROW. I was about to CRY in the computer lab at school when I saw your post and you SAVED 40% of my grade my friend, I owe you so much I decided to sign up and POST this comment thanking you SO MUCH. My gratitude can only be expressed by HOW MANY CAPITAL LETTERS I HAVE USED. I cannot thank you enough. Sincerely.


#20

Still broken. Autosave works from the command line and I can see the file, but doesn’t work automatically.