Autosave problem - coming at you since 2013 (at least)


#1

Hi there,
It has been a while that I wanted to post this, and many hours of work have been lost, what up with the autosave files?
I saw multiple threads that have no solution to a seemingly important and basic problem (I apologise that I have not read them all and add yet another one - my only hope is to be able to soon add a SOLVED to the title).
The description of the problem is the same as many others, I see several Autosave files with different names (since I often work with multiple instances of Rhino open) but all old and none related to my recent crashes. It is frustrating in a time when Windows shuts down for updates automatically if you are away from your desk (not a rhino problem I agree). I have lost several hours of work this week and several in recent weeks.

Any help would be welcomed,
N


(Pascal Golay) #2

Hi nsgma - one possibility suggested earlier is to add the Save command to the Options > Idle Processor page and set the timer for whatever makes sense - 20 minutes maybe.

-Pascal


#3

Does the Idle Save approach give different autosave files for different simultaneously running Rhino instances?

// Rolf


(Pascal Golay) #4

Hi Rolf - the Idle Processor Save trick is the Save command, it has nothing to do with Autosave.

-Pascal


#5

Ah, OK! :upside_down:

That solves the problem.

// Rolf


#6

Hi @pascal
As far as I understand that will save my file if the processor will go idle. I don’t really want that my model is saved automatically without my knowledge. I could also make it save before Rendering or any other action, but that’s not what I want. What I want is really for autosave to simply work. Is that really impossible?
N


(Wim Dekeyser) #7

Autosave does work. If it doesn’t in a certain case on your side you will have to provide specific information on what goes wrong. Note that in the case of Windows updating itself it seems that Windows can make Rhino shut-down without asking for saving anything but that is beyond the control of Rhino.

Only partly related: are you sending in crash reports on those crashes that you are experiencing?


#8

So I have been waiting to check if the autosave works as has been described in this thread. And after a few minor crashes where I did not lose too much, I just had a bigger one after a very productive Saturday night… or so I thought it would turn ou to be.
So I crashed, send the report as I always did (by the way) and immediately clicked the file to see if it told me that it had a autosave file… to make a violently cursing story short… it did not! It simply opened the file from several hours ago (… I know, I know I should have saved it more often… don’t make me curse…)

Now can somebody explain to me this erratic behaviour? The last Autosave was from yesterday night on a crash that I ignored because I did not lose anything (but in any case it did not ask me if I wanted to recover it when I reopen the file).

This is really, really failing.


#9

So you would be better off if Rhino DID save your model without your knowing. Set Incremental save in the Idle Processor and the worst that will happen is that you’ll have a bunch of extra files to delete at the end of the day but your work will be intact!

Thanks,
Dennis


(Pascal Golay) #10

What do you mean by this? Normally Rhino should tell you you have an Autosave file available when you next open Rhino - I think that is what you mean but I’m not sure.

-Pascal


#11

Beware,

 In the last couple of weeks I have been getting unwanted Win 10 updates despite me wanting notice and permission before such and on a recent update I was losing work because of no autosaves. I have always had 10 auto saves turned on in Rhino but was shocked to see that it was unchecked and suspect that a Win 10 update had something to do with it. I know it sounds paranoid but better check to be sure!

#12

I guess you are right, but since Rhino kind of hangs every now and again to make an AutoSave would it be too much to ask it to work?
N


#13

Hi Pascal,
I mean I clicked the file I was crashed with, as it was described that should be done. I normally open a Rhino file by clicking on it in Explorer. I don’t start Rhino and then open the file… would that be a problem? … the problem?

Yesterday, it happened again and I lost the whole evening of work. even before I open the file I checked the AutoSave folder and there was no AutoSave file for the file, but I do remember Rhino saving AutoSaves.
N


(Pascal Golay) #14

So, Rhino crashed, and then you looked in the Autosave folder - before starting any other rhino sessions - and there was no Autosave file, is that correct?

Can you reproduce this by using Save then the Autosave command (look in the folder to confirm) then testCrash (defaults) to crash Rhino.

thanks,

-Pascal


#15

So when I do AutoSave it creates the AutoSave file. and then after testcrash it keeps the file, and then when I open the file from windows explorer it opens the AutoSave file… So everything as expected… why doesn’t it work when I have a "RealCrash" ? :wink:
N


#16

I agree. There’s a great script for 3ds Max that does exactly what you want. I wish someone would write one for Rhino!


(Pascal Golay) #17

Hi N - are you crashing from plain Rhino (real crashes) or is a plug-in involved, maybe?

-Pascal


#18

@pascal
difficult to say. I do have a plug-in of TheaRender but I do not think I have crashed only when I was using functions associated with it.


(Pascal Golay) #19

@JohnM - do you have an idea of what to check? nsgma repeatedly gets crashes and no autosave recovery process on the next startup, but testing ‘by hand’ : Autosave then testCrash and restarting Rhino does work as expected.

-Pascal


#20

@dmoyes
Is there a way of doing an incremental save regularly? I mean, if I understood correctly, if I set it in the Idle Processor it will only saves it incrementally when the computer goes to sleep. Is that it?
I am so desperate that a regular incremental save would be better…
N