Architectural model navigation

Hi all -

I am currently having a lot of trouble showing architectural models to my boss. I have been using Rhino for Mac for a while an am proficient at moving the camera when working on a model. However, using the camera to give a “tour” of the space is much different, and much harder for me (and by extension, much more frustrating for my boss.)

I see that Walkabout on the windows version is still not available on Mac. Is the command ever going to be added? It seems like it would be pretty indispensable for anyone looking at architectural models.

In the meantime, I could settle for a way to move the camera forward and backward without having to change the focus. What ultimately happens to me as I “walk” through a space is that the zoom maxes out and then i can’t move forward any more. I usually have to select an object and ZS to get a new focus in the next room. then the view jumps a lot and continuity is lost.

Or, perhaps there is a way to use the arrow keys to “fly” through a model like in a video game? IE moving the camera forward and backward at a constant rate rather than a “zoom”.

Someone please help us restore our sanity!


  • Chris

Walkabout is lame
– Bob McNeel

This was covered many times through several years. Because I also work with architecture I had a similar problem to you. I think all the people working with architecture in Rhino has a similar problem. I am really surprised that it’s not addressed yet because it just happened that Rhino got pretty popular in the architecture.

My solution: I purchased spacenavigator. Unfortunately, drivers for that device are also lame - so now it collects dust. I asked on the 3dconnexion forum to enhance some customization options and they did nothing.
My solution #2: I moved with this kind of stuff to UE4. Not only there already is CAD Datasmith plugin which updates your imported Rhino model pretty nicely, but they are working to make it better (texture mapping problems).

I think that McNeel treats Walkabout as an obsolete function and this is why they didn’t add it to the Mac version. However, there are still some moves on YouTrack, maybe @DavidEranen can say something about it.
There is one user who claimed that is working on a paid plugin to bring that function into Rhino (but in usable form) - @Jarek. Maybe you can throw pre-order money at him to keep him motivated :wink: .

The plugin is ready and I have been using it for a while now, but making it public with licensing and well tested takes a while… I am on-and-off on this project, it does not have the highest priority now. And - unfortunately - it will be Rhino for Windows only, so I guess it doesn’t help the OP on Mac.

Here is a quick preview from the older version of the plugin I recorded a while ago (it works much smoother now):

1 Like

For this issue, try holding ALT when zooming with the wheel - it should move both camera and target, so you won’t run into the “stuck” zone. I know this is not solving your general issue, but I thought I’d mention it.

@Czaja @Jarek Thanks for chiming in. I knew i couldn’t be the only one having this problem. I have googled extensively and only came to the forum after extensive googling.

@Czaja UE4 sounds fun, going to take a look at it. Thanks. I’ve ordered a spacemouse too as the boss encouraged me to throw money at this problem. I’ll send it back if I don’t like it.

@Jarek Your plug-in looks amazing. It’s exactly as I had imagined this should work. Really impressive model too! Also - I just tried alt-zoom and it will totally work for now. Don’t know how i missed that in my search. Thank you so much!

If any of the Rhino gods are listening, we humbly pray to thee for wasd controls.

  • Chris

OMG this is awesome! Is there any chance to contribute to beta testing? I promise I will not spam you with the features requests!

try twinmotion, a real time renderer, its free till November i think. all u do is export fbx from rhino and then import.