ArchiCAD|Grasshopper not listening on port 1337


We are having a problem where the ArchiCAD - Grasshopper Live connection plugin can’t connect to Grasshopper in one of our PC labs. I believe I’ve tracked it down to Rhino not listening on port 1337 when Grasshopper is started so appears to be a Rhino / Grasshopper problem rather than an ArchiCAD problem.

On a clean, working system I can see that Rhino is listening on port 1337 as soon as the Grasshopper plugin is loaded and then when ArchiCAD starts the LIVE Connection it connects to Rhino on port 1337. This doesn’t happen on our lab PCs. The plugin loads but it can’t be connected to as it’s not listening on

We are running Rhino 5 SR14 x64, Latest Grasshopper for Rhino 5 ( grasshopper_0.9.76.0.rhi ) and ArchiCAD 21 (v5021). This is running on Windows 7 SP1 x64.

I can’t see any firewall issues that would stop it listening and nothing that I can change in any Grasshopper settings and no errors in any log files that I can see.

Any hints or clues would be very useful in tracking down this issue…


1 Like