ARCHICAD - Grasshopper Live Connection

I am trying to connect ARCHICAD 23 to Rhino 6 using the ARCHICAD Grasshopper Live Connection. Previously this worked like a charm (Rhino 5 - ARCHICAD 22), but now with ARCHICAD 23 and Rhino 6 is does not connect. I am working om MAC OSX 10.5.3 and I tried lots a basic troubleshooting like reinstalling both programs and restarting fresh and so on, without succes. Both the Grasshopper ARCHICAD plugin works (menu is visible, nodes can be placed), and the ARCHICAD Add-on can be started, but no connection between the programs can be made.

Hoi - Have you tried contacting Graphisoft about this issue?
There might be relevant information in their knowledgebase…


-wim

Thanks Wim,
Yes I did, I work at one of ARCHICAD resellers in the Netherlands, so we have an excellent channel with Graphisoft but they could not solve it either.
They supplied me with a small python script which was able to create a wall in ARCHICAD. That should demonstrate the ARCHICAD add-on worked.
They also pointed to the settings of the Port Number on which Grasshopper and ARCHICAD communicate, but that was exactly the same

Hi - The ARCHICAD - Grasshopper Live Connection is a Graphisoft product and I’m afraid we have no way of helping with that issue. Unless, that is, someone presented a few lines of Rhino-specific code that used to work and now no longer work.

I take it that it demonstrated that the add-on didn’t work on your system?

Does Graphisoft know of systems where this works on MacOS Catalina and Rhino 6?
-wim

Thanks again Wim,
I think they have other Macs where this works.

This was the Graphisoft response:

I am afraid that with the test you just did (Running the Python Script), where the wall was created in ARCHICAD, proved that the issue is not from ARCHICAD’s side. ARCHICAD is functioning, and the connection add-on is functioning too since it could transmit the data through the same port! That was the purpose of this test to begin with. This means both ARCHICAD and the port are fully functional.

It seems now that this issue is unfortunately on Rhino’s side. Rhino is unable to establish the connection with the port. I suspect it to be a permissions issue as most cases proved to be.

I am afraid at this point I can only recommend you to contact Rhino support in this case as the problem most likely lies with them. It could be licensing type, restriction to the port, or restriction to the System Folder, which prevents read/write processes from occuring.

Hello @jdebruin,
I had a similar issue not long ago; I wanted to use the LiveConnection for a new project after a while. I have meanwhile upgraded to AC23. I found that I couldn’t make Rhino/GH and AC talk to each other. I realized that while AC23 and Rhino 6 and the LiveConnection plug-in were the correct versions each, the problem stemmed from a previously installed version of the LiveConnection, namely for AC22 on my system. So once I erased that one, it worked with the latest version (for AC23). This was on Win10 however, so I don’t know if I will help you, but it could be worth a try.
Best,
felice

Hey Felice, thanks for your input!
unfortunately I tried that. I erased the entirety of AC22 and the connection from my system, but the problem persisted.
Furthermore, when I try to install the 22-version plugin, the AC22-Live-Connection-installer now stated it cannot find Rhino…

Hoi - someone here would like to know if you are running to versions of Rhino on that machine. Do you still have Rhino 5 installed? Do you have multiple installations of Rhino 6 and / or a Rhino 7 WIP?
-wim

That was my first setup. I had Rhino 5 and ARCHICAD 22, then I installed/upgraded to Rhino 6 and ARCHICAD 23. That did not work. Then I had Rhino 5 and 6 uninstalled as well as ARCHICAD 22 and 23 Live Connection. Then started from scratch, installed Rhino 6 and the ARCHICAD 23 live connection. But without succes.

I got a response from Graphisoft. I turned out the Grasshopper connection is not yet suitable for the combination Rhino 6 and ARCHICAD 23. The solution is to use Rhino 5 and ARCHICAD 23. In the upcoming update this is planned to be implemented…

thanks for your contributions!

1 Like