Any way to adjust size of micro edges to be removed?

I have 1 Naked Edge in the model. When I Mark the edge, I can’t zoom in close enough to see more than 1 point. ! _RemoveAllNakedMicroEdges does not fix the situation. is there any way to adjust the size / tolerance of that command to make it remove larger gaps than default?


Hi Robb - I don’t think so - but in any case not all tiny edges can be fixed by this tool - your edge may not be a loop for instance, but a very short edge.

Feel free to post the object.


Thanks Pascal. Here is the object. The open edge is extremely small as you’ll see.groove_fail.3dm (12.0 MB)

Move your object from the origin of very distant coordinates to 0.0.0

Hi Rob - yeah, there is a nasty zig in the surface right there -

If you fix that and rejoin you get a proper microloop from the old edges, and RemeveAllNaked etc etc gets it.


How did you get that particular point display? All I can get is this →

Hi Robb - that is set per display mode, I have large points - 3 or 4 pixels and solid control polygon at 2 pixels. I like to see what’s going on…


Thanks for the thoughts about the display settings. I am referring to the fact that your control(?) points seem to be right at the edge of the surface and show per isocurve. Mine are off the edge of the surface and do not align with the isocurves. I did shrink the surface.

Hm - dunno, except I probably did switch to a parallel projection when I zoomed in really close- can you try that?