Antialiasing only when rotating view?


#1

First post here, please forgive any ignorance…

I’m using Rhino 4.0, latest service release, and an NVIDIA GT 520M card, drivers up-to-date.

Having some issues with anti-aliasing. When rotating/panning/zooming the view I have a wonderful, smooth, anti-aliased image, but as soon as I stop manipulating the view, I lose all anti-aliasing effect. Also, I have no anti-aliasing in Rhino Render, despite the Render Settings showing High (10x) AA.

Any help would be much appreciated.

-S


(Brian James) #2

Hi Sean,

I haven’t heard of this display issue before. I would check your Nvidia control panel settings for Rhino 4 and maybe set them back to defaults and then like this as a first test.

In Rhino Render, do you mean edges and isocurves aren’t anti-aliased once rendered? This post process line work doesn’t get effected by this setting, only the edges of surfaces and I believe curves would see AA smoothing. However, there is a great (and free!) realtime rendering plugin called Neon which works with Rhino 5 and Rhino Render and it does this AA automatically. You can check it out using the Rhino 5 eval too if you want.

Let me know if I can help further and post any renders or models too if you still have trouble with the Rhino Renderer issue. If the Nvidia application settings for Rhino 4 don’t help with the display of AA please also let me know.


#3

Hi Brian,

Thanks for the quick reply. I reset all my NVIDIA options to the default values (with the exception of AA) and that seems to have cleared the problem right up! Can’t say which setting was interfering specifically, but the display looks great so I won’t worry about it too much.

Still not getting any AA via Rhino Render, but I’m not particularly concerned as I rarely use it and I’ll be upgrading to V5 fairly soon.

Thanks for your help

-S


#4

Rhino render has it’s own AA setting in Rhino. Go into settings and adjust it.

In V4 you can also sett the viewport AA by using the hidden TestSetAALevel command.


#5

Yeah I’ve tried every AA level via the Rhino Render settings, but all yield the same result.


#6

Then you need to send a file and some images to show us, because it sounds like you are doing something wrong. Rhino render settings affect Rhino Render still images, and ONLY Rhino Rendered images. Not images rendered with any other render engine, nor the display view ports.

Other render engines have their own settings, and the viewports in V4 does not support smooth AA unless you override the driver settings in windows, or you use the testsetaalevel command. V5 is different.