Model space scale in annotations not working for all texts


I have texts in the same annotation style in my file.
I also have the Enable model space scaling enabled.
However when I change the scale, some change while others don’t.
Is there a way this can be fixed without replacing all the text that aren’t affected by the change in model space scale?

this happens when you have overrides in your dimension (then the override becomes blue see red rectangle):
use the dialog to remove the overrides:

@pascal @wim this should really be less hidden imo.

Even with doing this, I still have the same issue. No change…

But are you changing the model space scaling inside the dimension style? Because that’s the only place to make changes globally.

Yes. Tried both inside the dimension style and inside the text properties model scale, while making sure the overrides are removed. No change.

Can you share a file that shows this behavior? Because I’m out of ideas now.

I can’t find any other solution other than just redoing the texts, but this would be quite the double work at this point…
I’ve uploaded a file with one text that the scaling works, and one that it doesn’t.
Any ideas would be helpful.

text.3dm (61.4 KB)

It looks like this is a left over thing from Rhino 5. Do you still have Rhino 5? In that case you can copy the texts to Rhino 5 and for the refusing text enable the Layout Scaling checkbox. That seems to solve the issue. I tried to do it with scripts as well but could not find methods for it. If you don’t have Rhino 5 just send the texts of you file and then I’ll fix it for you.


Yes, that did the trick!
Good to know for future files…

Thank you!!

1 Like