Ambrosinus toolkit

Please refer to this topic to discuss or request support for my Grasshopper components.

Thank you in advance!

Please for more info have a look at the links below:


Python libraries installation advice
First of All, thank you for downloading the AI components!

1) for OpenAI components (light version, it means no “Edit” and “Variability” features) you can now avoid installing Python libraries but try using the new Ambrosinus Toolkit (since v1.1.1) - you can install it directly from Rhino: Tools>Package Manager → search for plugin name

  1. In case you prefer using the Python ghuser components (because it has more features with the very next AMbrosinus-Toolkit v.1.1.2), I suggest a clean installation:
  • Uninstall your python version (and if you can run the CCleaner registry cleaning task);

  • Delete the python folder from this path: C: (Users\luciano\AppData\Local\ Programs (replace luciano with your user name - it happens automatically);

  • Reboot your PC;

  • Install Python v3.7.5 (I have tested this one and it works, on the other hand, the latest version has given to me some issues in installing the python libraries) - IMPORTANT! you have to tick as below:

  • image

  • At this point Run cmd.exe (WIN key+X > Run > type “cmd.exe” without quotes;

  • Check if you have the pip module typing: pip help - in case of errors check the guide on this page;

  • After installing python 3.7.5 I noticed that you already have pip protocol so go on;

  • Install the openai library (or/and stability-sdk) - from cmd.exe you should see:C:\Users\luciano>pip install openai (luciano has been replaced with your user name);

  • You should see no errors (try reading all text lines) - WARNING strings are not an error (for instance it can tell you that your pip version is outdated: if you want to update it text:

  • C:\Users\luciano>pip install --upgrade pip

  • After this (hopefully with no errors occurring) instal in your C:\Users\luciano\AppData\Roaming\Grasshopper\Libraries the GH Python plugin (eventually with its DLL if available) - IMPORTANT! check on the GHA file (and eventually its DLL) that it is not “blocked” by windows, so right-click on it>Property>General and “unblock”;

  • If you want to add the OPEN AI KEY (or STABILITY KEY)to the environment variable of the WIndows O.S. you can - otherwise pass it as text in the grasshopper panel;

  • Reboot PC;

Please, take into account that some machines could have different problems independently from this procedure. I have tested it on different machines and seems to work properly. Anyway, let me know if you will encounter some different issues, please. Thank you :wink:

Extra tips/recommendations:
1. Please, be sure to pass in input only image which has the PNG file format;
2. I suggest using a full path name without space or one that starts with a number (or have also some special characters in the filename), name it as simply as possible: D:\Desktop\DALL-E\DEMO\Edit\test …


Very useful plugin!
I wandor is it possible to add Multi-controlNet in our toolkit? That would be more powerful!

Thank you for your message and advice! Currently, the best way to deal with these modules is to have good API documentation and integration. For instance, in GH it is very important to understand if it is better put in sequence more than one component. On the other hand, enabling the multi-CN option in WebUI could be more simple and I could add this feature to the WinSDlauncher for instance :thinking:

Anyway, if you have more info/documentation about it I will be glad to have a look at them to schedule/understand all the helpful feedback,

Thank you :slightly_smiling_face:


Hi Luciano,

Thank you very much for the library - I’ve been running SD locally with the web browser, and wanted to test this out in GH but somehow I’m not getting any output even though the port is connected and SD did seem to run in the background as shown in the CMD portion of the screenshot below (there’s indeed nothing saved in the output directory specified); wondering if i may be missing something obvious…

I have the exact same problem…

Hello and thank you for your message!

Let me say that the “SeeOut” component is a dynamic component, this means that if you move the ID slider it automatically will fix with the exact range of images that you have in the “Output” parameter (have a look at the “SeeOut” param description hovering the mouse on it).

Below are some tips about the requirements to run the latest version especially v1.2.1. Bear in mind that you need a clean and well-worked installation of Stable Diffusion (Automatic1111 project) and ControlNET v1.0 (while I am waiting for the full API support of the v1.1.X).

Some useful tips (hopefully) :blush:
After the release of ControlNET v1.1 (but not fully supported by APIs), I decided to realize a video demo about how to install the AUTOMATIC1111 project with ControlNET v1.0 and v1.1 versions. Currently, the CN v1.1 is not fully API supported yet. So I suggest proceeding to a clean installation of the AUTOMATIC1111 project + ControlNET v1.0 extension.

What I have done if I encounter this issue:

  1. I passed the DirPath where I installed SDloca with ControlNET v1.0 as input of the “LaunchSD_loc” component (top left);

  2. I passed the DirPath (a custom one on my desktop) in the “AIeng_loc” component;

  3. I passed an image (right-click on the “path” component “Select one existing file”):

  4. I run the “AIeng_loc” component through the toggle button (generally, I avoided using the simple “button” for these components, otherwise no “Info” will be displayed from the AIeng_loc component);

What would I suggest?

  1. I assume that you have installed the standard Python as described here at point 2 - my version is v3.10.6 (see here)

  2. Try to install SDlocal + ControlNET v1.0 - please watch this fresh video :wink:

  3. Here you find the ControlNET v1.0 dataset model PART 1 o this article

  4. The demo Gh demo file for SDlocal from Ambrosinus-Toolkit

  5. The AT v1.2.1 (video here) is ready for CN v1.1 but waiting for full API support, anyway currently works well with CN v1.0. I added a little tool too and here you will find the demo file

    Finally, about some toggles… my little advice

  • GenWebUI could be a simple button;
  • if you use a button to run the “AIeng_loc” component you will be not able to see the “Info” embedded in the latest image generated (but you can do this thanks to the “SD-Imginfo” component if you like using the button component instead of the boolean toggle);

Hopefully, these tips aforementioned could be helpful. Please, let me know.
Enjoy your design exploration!


Hi Tobias,
Thanks for your feedback, please have a look at this extended answer.

Please, let me know.

Best regards

Hi Luciano

Thank you a lot for your time. Now everything works just right… the problem was, that i used the newest version of python and also control net. Python i had figured out by myself :stuck_out_tongue:, the other one took a while…

Looking forward for updates and appreciate your work!

1 Like

Happy to hear this! Cool!
Thank you for your feedback :blush:

Hello, I have a problem with the Ambrosinus toolkit

Can someone help me please? I installed the latest version using package manager but when I try to start grasshopper, this appears.

Hi Daniel -

You’ll need to update your Rhino version.

1 Like

Yep, thank you! Wim is right :+1::blush:

Thank you Luciano, very cool work right there. I have a slight issues. for some reason the images translated are not on white background and black lines, they are inverted and of a very hazy low res although the input is a good resolution. any idea what’s going on?

Hello, Thank you for your feedback. Did you check the ControlNET version? actually AI components (the ones based on the A1111 project) work fine only with the ControlNET v1.0 (the latest one isn’t yet fully API supported). In this case please, follow all the instructions reported in some posts above (or have a look here).

1 Like

HI, I’m having some trouble when trying to generate from Rhino, it automatically sets the CN preprocessor resolution to 64 pixels and generate a black image image with mlsd, sometimes it generates when i use depth. i believe its something with the CN, but wasn’t able to solve yet.

every image comes full black

Hello Gabriel,

Thank you for your feedback!

I assume that you have Stable Diffusion with ControlNET v1.0? Am I right?
Please, Let me know if changing the postprocessor resolution can help you solve this issue.
I am asking because I am trying to track different users’ feedback, you are the first that has encountered this problem, so it is my willingness to solve it and improve the tool.

Currently, I am facing a different problem (very similar to yours) in implementing the tool with CN v1.1. Please, let me know what version of CN you have and if changing the postprocessor resolution could be the most likely solution (so I will be able to release a new version with this option).

Thank you so much in advance.

best regards,

Thanks Luciano, i went to check the version of CN, i’m using v1.1, maybe it’s something wrong with xformers, i’m trying to check if someone had the same problem with the SD standalone and get back to you.

Thank you for the fast response :slight_smile:

Thank you Gabriel,

Basically, the current version works fine with CN v1.0 (the v1.1 isn’t yet fully API supported). In this case please, follow all the instructions reported in some posts above (or have a look here). Especially this part: " What would I suggest?"

1 Like