Ambrosinus toolkit

yep it was the controlnet version! rolled back to v1.0 and worked like a charm, thanks Luciano

1 Like

what should i do to resolve this error

my python version is 3.7.5

Hello Hassan,
thank you for your feedback.

Did you try to install a different Python version?
Please follow all the instructions reported in some posts above (or have a look here). Especially this part: " What would I suggest?"

Please, let me know :blush:

i am trying to export an image using the depth i dont know what happens please help

Hello Lama,

Thanks for your feedback.
Please, Could you detail your question?
Anyway, If you are using ControlNET please be sure that you have installed correctly everything especially CN v1.0. Currently, the tools work fine only with CN v1.0.

Please follow all the instructions reported in some posts above (or have a look here). Especially this part: " What would I suggest?"

Please, let me know :blush:

@Ambrosinus do you have a script for using the crop and modify method that you do using DALL-E; but instead you can use the local stable diffusion?
I know there is a method to do that in the GUI as explained here (https://stable-diffusion-art.com/inpainting_basics/)

Hello, thank you for your message. Yes, is it possible asap I will try to integrate one or two new component/s that can run the image 2 image process or something useful for the inpainting feature…

Hi Luciano,
I followed all steps and got the definition running. When I push the button to start, the shell shows up a calculation, but there are no images stored. After the calculation the LA_AUeNG" node in gh shows an error “solution:exception: index out of array”
Any ideas?

Thanks in advance,
Thomas

Hello Thomas, thanks for your feedback.
Please share with me your files (gh and/or images) I will test them asap…
Please, be sure to have installed the right version of ControlNET (the plugin works with v.1.0).

Hi Luciano,
thanks for the hint. Going step by step through your tutorial actually installs the latest version of controlnet. I found the archived version 1.0 on github, but it seems there is no elegant way to get rid of the newest version of control net. I will reinstall everything to make sure I have got only v1.0 running.
I will keep you updated.

Finally it works! Thanks for your support and your great work to push this new approaches to a end-user level!

1 Like

Cool! Happy to hear your words! Thank you for your feedback! :slight_smile:

Hello Luciano,

Thanks for the plugin. But after installation I find this error


MM_SD_Local_ControlNET_v10-11_v123_base&server_demo-01_v02.gh (71.8 KB)

attached screenshot and script for reference

also I get different image all the time

Hello, and thanks for your message here! :slight_smile:

I believe that there are some issues with the installation process and AUTOMATIC1111:

Actually, that gh demo file works fine with this configuration:
Python 3.10.6 (my actual Python version), I noticed that the 3.11 or the latest one generates some problems in running Automatic1111 (APIs).

Moreover, I suggest installing ControlNET v1.0 as described in this video especially at 00:52, and eventually, have another folder with AUTOMATIC1111 + ControlNET v1.1.x (so in the future or with my WinApp you can switch between them - the App is the one shown in the previous video).

Finally, I suppose that you have already downloaded the v1.2.3? because the Automatic1111 has been updating in this period his code and I am fixing some bugs when they come up in the Grasshopper plugin.

I am updating the toolkit at v1.2.4 just to have the opportunity to select the “processor resolution”, currently at 64 and fix the “guess mode” alert during the running.

Please, let me know. :wink:

Hi Luciano,

I indeed installed from here GitHub - lllyasviel/webui-controlnet-v1-archived: WebUI extension for ControlNet (v1 archived)

I just found out that my canny.pth is not working and causing error. So reinstalled extension and re saved.pth and now it works.

Thank you for this work! Great job!

Also is there a way to create multiple images? because it throws out of array error

1 Like

Happy to hear this! :blush:
Thanks for your feedback.

About multiple images, basically, when you change the “N” value it can generate more than one image according to the value set. Sometimes, the process can generate a “timeout error”, so that is why I gave the possibility to set up custom “Timeout” values (expressed in min/s, for example, Timeout=20=> 20 mins, the default value is 10 mins).

Anyway, if you want to share with me your setup and base image settings, I can try to emulate the same error and try fixing it :+1:

Hi,

Time is less than 10 mins but still it shows error
image

@Ambrosinus kindly help with multiple image issue