Altering Cplane Front is now Bott view but Back becomes Back so no top view available

I have an object which is composed of a vertical block and a sloping item.
To work on the sloping item one needs a Cplane to suit its orientation,

making such with X and Y as per the default directions and Z on its leaning backwards face, Top view is now front, Front is now underside (Bott)
However I need to be looking down as before on its top, without seeing it sloping.
I choose Front and set view to Back and I get the back., but the original back with item sloping.
If I alter Top view and choose Top I get the original top with item sloping again.

What do I have to do to get the top view as the top but without seeing Item B sloping ?
here is story board of method and effect,
also the file simplified.

Cplane top is not top.3dm (754.6 KB)


HELP !!!
I am dead in the water, no TOP view available,…help please…drowning !
need a TOP view.


Hello - if you need a world top view, use SetView > World >Top; if you need a plan view of the current cplane use the Plan command.


Do you have “Standard construction planes” or “Universal construction planes” selected in Options > Rhino Options > Modeling Aids > Construction planes? If Universal construction planes are selected then when you change the CPlane in one viewport the CPlane in the other viewportss will also change. Use Standard construction planes to change the CPlane in only one viewport.

Pascal, If I have Top view windows active and type Plan in the command line and hit enter nothing happens, I still have a view of the front.
If I was in the ‘Front’ view, which is giving me a 'bottom ’ view, would I type ‘front’ or what to get a front view ?
though as Plan didnt do anything I dont suppose front does either.

David. I am with Universal, though if I alter Top to Bottom I dont find other viewports change though.

anyone…If I have made a custom CPlane, what gives me my Top view in the window where before doing so I was looking at a top view. Likewise Front and Right. I want those windows delivering the views as at CPlane01 but of the object no longer at a slight angle.

I just can never fathom out how these useful views windows lose those views when I have the object almost same as before regards relationship of X Y Z axes to it.

So much so I in fact dread having to create a custom Cplane as the views dont give me the named views I expect, and if e.g I alter Top to Bottom I lose the custom Cplane and the item is back to being an angled view.
To be unable to choose a top or bottom view of the object unlike when Cplane01 is in use isnt right.

I did a test of a mockup aircraft to get my head around this and whilst default views gave me the front top and right side views as expected, creating a custom Cplane to e.g. be able to work on the wing gave me an upside down front view or things like that.
If there is anywhere that explains how to create Custom Cplanes and have top still provide a top view etc etc I need to see it.


I cant go on with this project without a top view, …
unable to get a TOP view for my custom Cplane, if I choose TOP view I get the default top view, item is onec again angled to my view as if in Cplane01.

How does one create a Custom Cplane for this item and have a TOP view for it ?


Here’s my quick steps for creating a quick custom cplane.
1, (Cplanes Tab) cplane to object pick one surface.
2, (Set view Tab) Click Plan view of cplane.
3, (Set view Tab) Now you click through the Set view cplanes.

Try this:

Create the custom CPlane
SetView command
Pick CPlane as the desired coordinate system (not World)
Select Top as the desired camera orientation. If you are looking at the wrong side select Bottom

Hi, trying Stratosfear first,
if I have a surface I can use as indication of where I want the grid running through, I click that,
If I do this in perspective view then at step 2 select Plan view I lose the perspective view.
I need to activate the top view panel, then select PlanView. that works :slight_smile:now I can pick my way through the seaplane logos.
initial testing looks good.
However if front view is active and I pick seaplane icon front, I get bottom view, if then I activate right view and click seaplane icon right I get the back view. I had to turn layer palette off to see it, I tried to drag hand it out from behind but it started rotating as if perspective view, normally the ortho views will drag across. So thats another issue being unable to drag.

tried setting Cplane using the XY method I normally use, followed your steps, with top view active I selected Top and got Top, :slight_smile:
Then with front view lower left active pane, I then went through this SetView command again, selected Front for the front view but got the bottom !

To have to run the command each time I want a view is a bit of a pain, if I can just activate pane and click a seaplane icon and get that view, thats it.

using the set Cplane to Object as per Stratosfear, using top view to do so, then with front view active running that SetView command again, select front and yet again I get bottom view.

So neither of these two methods deliver front view, or right view. and there is that drag makes rotate issue as well.

At least now I can get top but I cant get anything else !
Why is Cplane custom such a pain ?

Do other progs do this ?


SetView World Top will get you the world top view no matter what CPlane is active. Plan will show you the top view of the current plane.


The next step is saving named views. That way you have quick access to your Cplanes.

I do agree that creating a custom cplane is unnecessarily complicated and counter intuitive in Rhino.