All my connections suddenly turned orange - no display in rhino

Hello everyone, please I need help. I was working and then tried to turn on preview of rendered view, all of a sudden all the connections turned orange and then no display in rhino.

I even opened a new file to test and all connections there also turned orange and I wasn’t seeing any of the objects in the rhino window.
Please what can I do to recover my work?

Hi Hope,

Orange wires mean no data. Lets try turning off all the previews and refresh the grasshopper canvas.

Can you also type SystemInfo into the Rhino command line and provide the results here. Thanks.

Hi Japhy thanks for your reply! I’ve turned off alll previews. The systemInfo result:

Rhino 7 SR21 2022-7-27 (Rhino 7, 7.21.22208.13002, Git hash:master @ c31aea87137a5d0de449338a7ef6856f49dd4797)
License type: Educational Lab License, build 2022-07-27
License details: Cloud Zoo

Apple macOS Version 10.15.7 (Build 19H2026) (Physical RAM: 8Gb)
Mac Model Identifier: iMac13,1
Language: en-GB (MacOS default)

NVIDIA GeForce GT 650M OpenGL Engine (OpenGL ver:4.1 NVIDIA-14.0.32 355.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 512 MB
Graphics: NVIDIA GeForce GT 650M
Displays: iMac (103dpi 1x)

Graphics processors
NVIDIA GeForce GT 650M (512 MB)
iMac (1920 x 1080)

USB devices
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices
Apple: Apple Magic Mouse
Apple: Apple Wireless Keyboard

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino “RhinoCycles” 7.21.22208.13002
/Applications/Rhino “Snapshots” 7.21.22208.1002
/Applications/Rhino “Grasshopper” 7.21.22208.13002
/Applications/Rhino “PanelingTools” 7.21.22208.1002
/Applications/Rhino “Commands” 7.21.22208.13002
/Applications/Rhino “Renderer Development Kit” 7.21.22208.1002
/Applications/Rhino “RDK_EtoUI” 7.21.22208.13002
/Applications/Rhino “Displacement” 7.21.22208.1002
/Applications/Rhino “Rhino Render” 7.21.22208.13002
/Applications/Rhino “IronPython” 7.21.22208.13002
/Applications/Rhino “Legacy Rhino Render” 7.21.22208.1002

Thank you!

Are all the plugins you using supported by Mac? any new ones you added to the definition recently?

Perhaps breaking out some portions of the script into a new files for testing. Disabling downstream components is also a good troubleshooting method. Slowly enable the components starting from left to right to see where it goes off the rails.

I installed some plug ins a while ago like parakeet python and some others but they have been working just fine until this happened

I tried to start a new test file but even those ones too show orange wires and no display in rhino
What are downstream components please?

Creating a new file and placing components isn’t working? or are you copying and pasting the contents of the old? Can you post or send us the file? Thanks.

Silly question. But have you accidentally disabled your solver? Under menu : solution > enable solver

you’ll see a lock icon if GH’s solver is disabled.

1 Like

thank you all so much, I turned it on today and everything “magically” returned to how it was! I was going to check the ‘enable solver’ you both suggested, its enabled but hopefully this doesn’t happen again lol


1 Like