Adjusting Scale of text in Rhino Layout?

Hi Guys,
The text is 200mm high and works well in my model space but becomes huge in the layout space (please see picture). What is the issue and how can i solve it?
Many thanks,
Arthur

Hi Artur - set text height to be correct in layouts, then set scaling for model space in DocumentProperties > Annotation page.

-Pascal

2 Likes

HI @Arthur_Mamou_Ma,
All the layout scaling of text and dimensions also messes me around alot since Rh5.
Rh4 was simple. ie. Use 1:1 in model space and then scale the entire Layout Detail in one go and everything scales together.
The idea in v5 was to have the text remain the same size in different layout detail scales, but for the most part it is just a headache.
Easiest way to use 1:1 WYSIWYG text in model space and still use the more global Detail Scale in Layout is to select the text in model space, Press F3 for PROPERTIES and un–tick the " Layout Scaling" option.
The text will now be visible in layout detail the same as it is visible in model space in proportion to the drawing etc. in model space.
I do the same for Dimensions and switch off the global layout scaling in the options, else you end up with some things scaling and others not etc. and you make a diagram with mixed linework, text and dimensions in model space which looks great and it turns into an abstract artwork in layout space.
So for me it is best to switch off all the nonsense.(Not trying to offend anyone, but this has wasted alot of my time since v5 came out.)
Yes, you can make it work using the scaling on, but then you have to setup different dimension definitions for each possible layout scale you might use and variation etc. and then assign the right def to the right dimension and then only use them in layout space, which then becomes a circus act of layout and model space… I’ve tried many variations and in the long run the v4 model space 1:1 method was better and much faster for me, and I produce many layouts.
WYSIWYG = What You See Is What You Get
Hope that makes sense. Michael VS

1 Like

What? That does not seem to make sense. What if you have the same drawing in various scales? If there is one setting that should be the “ruling” then it should be model space. I have the same issue.

Hi - this thread is old and was about a workflow in Rhino 5. In Rhino 6 you can set annotation scaling for model space and layout space individually. Which Rhino version are you running?

How can you do that? I was looking to find this setting but couldnt.

Hello @pascal, I also have the same issue and I wonder if there is a way to reverse this process?
Let’s say I have a text in model space that I use as a personal note then later on I want that same text to show in my layout but keep the scale as in model space. Normally in R7 layout space, my text will blow up in scale if I do so. Without recreating the text in layout space is there anything I could do to make the process more efficient. What can I do?

Hi Hogan -

The size of annotation text is defined in layout units. You’ll have to adjust the size and scaling of the annotation style for this to work.
-wim

Hi Wim, yes I do know that. What about “text” instead of “annotation text” in model space?

Hi -

There is no “just text” in Rhino. Everything is “annotation text” - except for “text objects”, but those are just curves or surfaces.
-wim

I see. So I guess the only way for the text to show up on the right scale in both model space and layout space is to go to layout space first, make the text and use “model space scale” even if I don’t need this layout at all? Is there a way to reverse this, as the same process but create text in model space and change the “layout space scale”?

Thanks

1 Like

If you are not using any layouts at all, you don’t need to worry about the scaling difference.

No.
-wim

If you are not using any layouts at all, you don’t need to worry about the scaling difference

Sadly I do. Sometimes I import DWG from other drafting programs and the text comes in fine in model space but it’s a hot mess in layout space. Can I make a wish to have this issue to be improved in the future, please? Text sizes are pretty critical to drafting. Thanks

1 Like

Hi Hogan -

It sounds like you don’t understand how that works.
You are using layouts. Fine.
The annotation styles are in layout units. Scale those for model space if needed.
-wim

I see what you mean and I understand how to add this to my workflow now. Thank you so much! @wim

What Wim suggests makes sense if we make text in layouts first, and then we realize that we also need text in model space. Unfortunately, it never happens. In the real world, we make the text in model space first, we realize it was a mistake, we make layouts, and we struggle with text size in the layouts.

1 Like

Hello! it is very simple to solve this problem (rhino v6). Go to: File + Properties + Document Properties + Annotation Styles. At RIGHT there are 2 options.

  1. Enable layout space scaling. Turn it off.
  2. Enable model space Scaling. Turn it ON.
    Lastly click Apply. Hope it works for you too! :slight_smile:
2 Likes