Adding dimensions to a dwg file


#1

Hello,

I’m pretty new to rhino/cad software so go easy. I have tried a search for the issue/tutorial but no luck.

I have imported a dwg into rhino and want to add dimensions to it, I selected the linear dimension option.
Once I have done the three clicks no dimension shows. Any ideas? Also found not all the detailing shows.

Is this a dwg to rhino issue does something need to be changed in preferences? oh and its on a mac.

thanks for any help


(John Brock) #2

There’s a Drafting tutorial on this page that might be a good start:
http://www.rhino3d.com/tutorials#rhinoOSX


#3

Hi John

The dimension option works if I start a new document. Its a supplied auto cad dwg that just won’t work, I need to add dimension for my construction drawings and time is tight.

thanks
Tom


(Pascal Golay) #4

Hi Tom - after you do this, add a dim that is, and it does not show, type in SelDim and Enter - does the command line report any?

-Pascal


(John Brock) #5

You’ll need to take the time to learn about named dimension styles and the settings that control how they look, or get some help from an experienced Rhino user, perhaps on a consultant basis to meet your time constraints.


#6

Hi Pascal

All dim lines become highlighted in yellow thats all.

cheers


(Pascal Golay) #7

OK, so there were some existing dims - what I’m after is finding out if your new dims exist at all - l ike John, above, I have a feeling they are there, and you need to change the sizes or something.

Try - SelDim Lock. Make your new dim, then SelDim again - anything reported selected?

-Pascal


#8

new dim highlighted in yellow, previous dims not. No numbers showing


#9

maybe you have chosen a pretty off scale, details can disappear.


#10

tired putting dims on drawings from 2 different architects, still no luck.


(Pascal Golay) #11

You’ll want to have a look in FIle > Settings > Dimensions and see what styles are available and fuss with these - modify to taste to get things sized correctly for your situation.

-Pascal


#12

This seems like the text and arrows are just really small. Are you placing the dims in model space, or layout space? If you are placing them in model space, you may want to change the model space scale. If you are placing them in layout space, be sure that the dimension’s layout sizes seem correct.

-Edit-
Pascal beat me to it.


#13

Thanks both of you, changed settings from standard to 150mm. Which also changed font and now dims show.

Thanks again for your help
Tom