Add Floor Error: Value is out of range

Hey all,

I have been facing this error and can not figure what the cause of the error is or what it means. The image below shows the error and the curves are internalized in the GH file.

Also, when I have multiple curves as input even if only one curve gives this error the component does not compute any of the other floors/curves… tried changing error mode and it gives the same result the component just doesn’t compute.

PS. these curves were created from hatch boundaries coming from AutoCAD hatches. (5.6 KB)

Hi @M.Tarabishy,

What units are those curves?
In order to create three Floors you should Graft the input else the component interprets the inputs as loops of the same Floor.

Hey @kike ,

The curves are in meter, and originally I had them grafted just not in this sample. Also, the main definition is 3000+ floors, and they all don’t run because of multiple curves that give this error… I have been selecting some and running them until I found these ones where the curves preventing the whole component from running.

Rebuilding the Curves clears up the issue (not sure exactly what segment is causing this though)

1 Like

There is a problem when the curve is almost an ellipse but one of the radii are greater than 30.000 feet.

In this case after exploding the curve into C2 segments there are two curves on the corners that produce this error.

1 Like

Thanks for the info guys will try rebuilding and setting them in a bit.

And, is there a way to make the component run and leave the faulty boundaries as null instead of not running at all ?

Continue mode just skip known errors with known solutions, but in this case is an unkown error the component is unable to recover from.

I’m working on a fix.

I have tested rebuilding the curves with radii more than 30,000 feet and it worked for the curves I had previously excluded to cause the error.

Unfortunately there is something else that is causing value out of range error with some of the boundaries not sure which ones yet, so I will try and find them and let you know.

Was also wondering if there is some documentation or reference to check and know about what causes errors, or is this something related to Revit?

I order to be rcognised as an Ellipse should be a Rational Degree 2 curve that fits as a perfect ellipse under Revit tolerance that is 0.1mm aprox, in this case and only in this case if the resulting ellipse has an axis larger than 30.000 ft it fails.

Current Daily build has this problem fixed.
Next 1.8 RC will include it as well.

Great, thanks :slight_smile:

Hey again,

So I was facing another error with floors as shown below in the video ( Constraints defined by the sketch couldn’t be satisfied), the top curve cannot be created directly, but when created after the bottom curve it doesn’t give an error.

Units are in meter again.

Top Curve: generated using Elefront deconstruct hatch > boundary from the dwg hatch file below opened in Rhino.

Bottom Curve: generated by importing the dwg in Revit > exploding it to generate a detail item Fill Region, and then extracting it’s boundary using graphical element > element geometry.

PS. notice the curve length difference between the input and output.

Floor (13.5 KB)
Hatch.dwg (411.6 KB)

What’s the error message? :pray:

To confirm, when you say meters your Rhino file is meters and revit is set to meters as well.

I’ve tried in Ft and Meters with no errors. I am seeing the difference in curve length.

Rhino.Inside Revit: 1.9.8202.15545 (2022-06-16T08:38:10)

Rhino: 7.20.22165.13001 (Rhino 7)
Revit: 2022.1 (

1 Like

Yes, that’s what I mean by in meters… both Revit and Rhino setup in meters.

Error message was… the constraints of the sketch defining the highlighted element cannot be satisfied

Using latest Daily Build for RiR, will try with a previous one and let you know.

Tried the public release and still getting the same error… not sure why you are not getting it hmm

Units tolerance is a variable.


I checked the tolerance and it was setup in the same manner as yours (the default) and still had the error.

Since I have Revit version 2022 ( and yours was different I checked with Revit 2020.2 since I had it installed and the error was gone… so it is something related to Revit not RiR.

Thank you for the help :pray:

1 Like