A technical problem on grasshopper

Im using the latest version of Rhino - rhino 7 and I created a code on grasshopper which works perfectly. the problem is that when I am trying to insert a shapefile to the component of a shapefile - i am getting as error message like there is no data in the shapefile (which is not true). do you know how can I solve it?

welcome on the forum. It will be hard to help you with so little information. We have some Wizard but not like Harry Potter or Gandalf and no :crystal_ball: !
Is ImportSHP your plugin ? If not which plugin ? What is the exact error message ? Is the SHP opened by other GIS tool ?

What is it ?

You could read that also

iirc importshp is built in.

sorry if my msg was a little bit massy. i am attaching to this msg the grasshopper code i worked with. i used urbano plugin and inserted osm files and everything worked, but when i wanted to insert a shapefile (using the component of import a shapefile) i have got the error “solution exception cold not find file…dbf” why it wrote dbf if it is a shp file? and why it made this error if there is data on this shapefile

i am attaching the shapefile, the osm file as a link and the grasshopper code as a zip folder

thank you for your help

Hi -

See the FYI here: