3Dconnexion mouse controls are reversed in WIP (compared to Rhino 6)

I’m having problems using my 3Dconnexion Spacemouse in the latest WIP (7.0.20056.13055, 02/25/2020).

The Spacemouse works fine in Rhino 6.

I did a side by side comparison between Rhino 6 and the WIP. It looks like the control directions are reversed between the two.

For example, if I twist the Spacemouse counter clockwise, in Rhino 6, it rotates an object counter clockwise, in the WIP, it rotates the object clockwise. All control directions seem to be reversed.

I have the latest driver installed (3DxWare 10.6.5, 3DxWinCore, and all settings are at their defaults.

What is the difference between the way Rhino 6 and the WIP handle the 3DConnexion Spacemouse?


I haven’t noticed that, are you sure you haven’t touched the defaults in both installations?

Hi Ivelin,

While I was double checking the defaults to answer your question, I figured out a work around:

“Rhino->Options->3Dconnexion SpaceMouse” just says to “Use the 3Dconnexion Properties in the 3Dxware driver to congure”

I can reverse the controls in 3Dconnexion home settings application under “Advanced Settings”.

The problem is that the Rhino 6 and the WIP use the same 3Dconnexion settings, but for some reason the WIP reverses the control directions.

As a work around I can save 2 versions of the 3Dconnextion settings for Rhino 6 and the WIP.

I’m suprised no one else has encountered this problem.


1 Like

I believe the different configuration switches automatically depending on the application that is active.

I use different speeds for rotation in Rhino and 3DExperience. No need to manually switch any configurations.

I agree, for most applications, but I don’t think that the 3Dconnexion software can distinguish between Rhino 6 and Rhino 7.

@markus, can you look into this?

Unfortunately, I can reproduce the reversed rotations and translations in the WIP and do not know what the cause is, yet. However I can recommend a workaround, that works for me.

Open the 3Dconnexion Properties application (right click the 3Dx icon in the taskbar)
Ensure that the WIP has 3Dmouse focus.
Press the ‘Advanced Settings Button’
Change the ‘Navigation Mode’ from ‘Target Camera Mode’ to ‘Object Mode’ and back again.

For me both Rhino versions now navigate the same, similar to moving a camera. If you want both to use an examine type navigation, then, with the corresponding version of Rhino with 3DMouse focus, change the navigation mode to ‘Object Mode’.

Reversing the axes in the ‘Speed’ dialog is generally not really a good idea.

I am slightly concerned that ajohnblack says “if I twist the Spacemouse counter clockwise, in Rhino 6, it rotates an object counter clockwise”: the default navigation mode is ‘Target Camera Mode’ so that twisting the cap counter-clockwise should result in the object rotating clockwise.

Hope this helps.

1 Like

I can confirm that something in 7.0.20035.14285 caused an axis flip. Restoring a backed up config did not fix the issue, I had to manually set it up again.

I didn’t try R6 at the time, but comparing 7.0.20056.13055 to R6, they operate identically and use the same 3dx profile (RhinoFS.xml).

R5 uses a different 3dx profile (Rhino.xml).

@ajohnblack Can you see if you’re using the same navigation mode in R6 and R7? I’m just realizing that Object Mode and Target Camera Mode uses an inverted axis setup. Look’s like Rhino’s _SpaceMouse command takes precedence over 3dx’s config panel and you can have it set differently in R6 and R7.

Maybe that’s what happened, the WIP changed the _SpaceMouse setting from Object Mode -> Target Camera Mode. Old config didn’t fix the issue, and I’m not sure what did. I started tinkering with everything until it worked again.

1 Like

Same issue 3 years later with Rhino 7 / Rhino 8 WIP.

This post got me back on track. Thanks !

1 Like

Latest WIP installer have reversed axes for the 3d mouse. (using just the 3dconnexion plugin integrated with rhino)

1 Like

Hi Riccardo -Are the settings the same in both? ( Object mode, Target Camera mode, Helicopter mode etc)

1 Like

Yes, same.
For now I’ve solved by coping 3dxrhino.rhp file from 7 folder to 8 WIP one… :upside_down_face:

1 Like

I just saw a Rhino crash report submitted a few days ago where Rhino crashed in the 3dxrhino plug-in. Was this before you moved files around?

1 Like

Oh! Well spotted!

applies only if the 3dconnexion USB (wireless dongle) is connected. (not even touching the 3d mouse)

I replaced the rhp file and I’m not sure what version is now and how to revert to the one shipped with current WIP… reinstall?

1 Like

This has been found and fixed.

Thanks for the report.


1 Like

I just downloaded the beta and it’s reversed, so I’m guessing the fix is not public yet?

1 Like

The fix was for the crash and had nothing to do with how a space mouse behaves.


1 Like

Ok… so is this Navigation Mode something we all set once upon a time and then collectively forgot about?

Also, I’m seeing occasional random “jumps” in camera positions which is quite distracting and reduces productivity…

Hi guys.

Im having the same issue.

Actually is not only in reverse in Rhino 8 Beta, but it resets all the settings in my 3d connexion mouse that I have configured for Rhino 7 once I open Rhino 8 beta.

When I return to Rhino 7, It doesn’t go back to the previews settings so I have to export a file from the mouse software with all the settings and re import when I return to Rhino 7 so I dont have to manually set the settings every time I try the beta.