3Dconnexion Enterprise: works except for Front, Right, Top view buttons


My 3Dconnexion Enterprise 3D mouse makes me MUCH faster in Modo, and also in Rhino except that in Rhino, the buttons that control Front, Right, Top views, and the Fit button, cannot be set and don’t work in their default configuration. I talked to 3Dconnexion and they say that McNeel needs to download their free SDK and make some tweaks.

The Enterprise has a dozen buttons across the top that I can assign to fire a keystroke combination or a macro that I assign. There’s a screen above those 12 buttons that shows the name of the macros I gave to those buttons. They work perfectly. So do the view buttons labeled V1-V3 The Iso button is also assignable. Unfortunately the highly important F (front), R (Right) and T (top) and Fit buttons are not assignable, not even when assigning a single keystroke, and they don’t do anything by default.

3Dconnexion officially supports Rhino for Windows but not officially for Mac.

Here is an excerpt of 3Dconnexion’s email to me:

“Adding 3D device support to an application is determined by the application developer rather than by 3Dconnexion. We have an SDK [Software Development Kit] which any software developer of the application vendor can download at no cost and which allows the integration of 3D device support in any software:

As a workaround I can assign V1-V3 to be Front, Right, Top but the big strength of these assignable buttons is that the muscle memory associations between a view and a button are the same regardless of the application, be it SketchUp, Rhino, Modo, etc. So I’m messing myself up a little by breaking that consistent association.

Hi Gregg
I used Space Mouse Pro but I did not have difficulty programming the F, R, T keys according to my needs. If you want to program them for the views, I think it’s enough to create a shortcut from the mac system preferences.

I tried to set the F key as “Front” and it works perfectly. Here are the steps (I am in my language, if I need help I will provide it)


Thanks Simon.
I had the hardest time trying to figure out how to assign shortcuts to commands.
I finally realized that I could do it in Rhinoceros->Commands->Customize.
By typing “front” in the search field at the very bottom of the window, the Front View icon appeared among the search results.
Clicking that icon revealed a Keyboard Shortcut textfield.
I hit Option+Shift+F to assign the shortcut.

The moment I assigned the first shortcut by this means and saved it, the non functional buttons began functioning. So after assigning only one shortcut and saving it, the T, F, R buttons worked. (Not their alternates: Back, Left and Bottom)
REASON: I migrated from Rhino Windows to Rhino Mac and my Alias file came along from windows. I believe something previously saved in that file was the issue.

At that point it was merely a matter of assigning shortcuts to all view commands including Back, Left, Bottom and assigning them to 3Dconnexion buttons.

So in the Mac System Preferences->3Dconnexion->Buttons tab, I chose “Button F” and assigned that shortcut.

It works fine. I then continued with all other button assignments and all is well.

The FIT button was an entirely different solution:

In the Rhino->Preferences menu, there’s a 3Dconnexion option. That might only appear if you have a 3Dconnexion device enabled, not sure.

I chose 3Dconnexion and saw this menu:

I pressed the FIT button on the 3Dconnexion device and the empty textfield for “Button 2” on the menu lit up.
I already had the alias “ZE” set to ZoomExtents from my old setup so I just entered that in the textfield. The textfield would not accept modifier keys as keyboard shortcuts, only a text string.

Here’s my Rhino Preferences->Aliases window:

These Macros were generated in Rhino Windows as well and apparently Rhino Mac doesn’t have a macro editor yet. I’m confused about that, maybe I’m looking right at it, but regardless, the Alias was previously assigned to the macro in Windows.
Recognizing that Shortcuts and Aliases were very different things was an important step in resolving this issue.

At any rate, that completed the necessary settings.

I hope this helps anyone else who might be having such an issue.

OOPS… new problem:
Of course when I select the Perspective view, it goes to the default perspective. In other words, the camera is in the default position for perspective, the perspective camera is not where I left it when I was last looking at the perspective view.
(That’s going to get old VERY quickly.)