3D Space Explorer with Rhino 6 on Win 10

Hi there,

I 've got an issue with the space explorer. It’s working fine since long years, but when I turn the actual model and get close to the model the space explorer zooms out very far, so the model becomes invisible. Moving, zooming and rotating the model my mouse works fine. And often it works with the space explorer too. Just sometimes it won’t let me work.
Seems there’s some geometry which causes this, as I encountered this only in that specific file.
Copying the data to another file didn’t work, as well as purging.
There’s a lot of geometry in this file, it has almost 2GB, a grown file. So copying all needed geometry is also not easy.
Last option rescue?

Thanks…

Let me mention also, that this happened on two different computers.

Hello - if you Zoom Extents, does the camera zoom way out or do you see the expected model?

-Pascal

Not sure if that’s the case here, but Rhino 6 introduced a weird issue that happens while trying to navigate close to objects whose rendering style was changed via the “! _SetObjectDisplayMode” command. That was not a problem in Rhino 5.
For example, if there is an abject whose display mode was changed to “Wireframe” and you try to look around a distant object behind the former, the automatic point of rotation will be set to the “invisible” wall of the nearby wireframe object rather than the visible geometry of the distant object. It’s a super intrusive bug.

That sounds like it. You don’t have a workaround, do you?
I don’t work with written commands, so I’m not sure if this command was used by clicking icons or so.
Can you tell, how this would happen with icon-commands? Or another way?

I have checked if there are any small objects far out of the regular model extents.
Have imported for example many drawings from the designer.
But I have deleted all old stuff I could find and also delleted the model piece by piece. Without finding any wrong objects.
I cannot tell when it happened first, have been working long time with issue.
Therefore I also do not know what I did before this ocured.

Hello Pascal,
if I zoom extents, I see the model.

You can access the command via the upper panel. It’s explained in detail in the following link (just click on the plus icon next to “Where can I find this command?”):
https://docs.mcneel.com/rhino/5/help/en-us/commands/setobjectdisplaymode.htm

Thanks… As I understand this, I need to know which item causes the bug
and change its display mode back.
That will kind of difficult with a few 10.000 objects.
Sh…t… :slight_smile:

To revert these changes, you can do one of these things:

  1. Either use the “ClearAllObjectDisplayModes” command.

  2. Or try the following “hack”:
    a. Use the “’_4View” command.
    b. On the Perspective viewport, press the small arrow on the right side of the “Perspective” name, then on the drop down menu go to “Set view”, then under “Named views” see and change the viewport to some of the other custom viewports that you have (if you don’t, create one).
    c. Then activate the “’_4View” command again.
    That should reset your objects with custom viewport mode.

Thanks!

I tried both.
There were 132 objects with custom viewport mode, which were resetted
with the “ClearAllObjectDisplayModes” command.
I tried then to rotate the model, it still did jump out of way. I saved
it and restarted rhino, but still did it.
Then I tried the hack, but without any change.
It still jumps out of range when I come to close to the model.
Especially when I look to it from left view, unimportant what name the
viewport has and if perspective view or parallel.
In plan view it works fine, bot rotating the model will let it jump out
of visibility.
When I zoom close to it with the space explorer, stop it for a moment
and start rotating and zooming again it will zoom out a few kilometers.
Zooming and rotating with the mouse works fine.
The left view viewport seems to be very sensible, to model jumps out of
way much faster.

With another model everything works as it should.

Does anybody have an idea?

No one an Idea?

Thanks for your time…

Hello - if you model is split up into layers, I would go through layers or groups if layers at a time, leeaving those on and the others off, to try to narrow down the object(s) causing the problem.

You might also run SelBadObjects, just in case - if any, delete or hide these and see if there is any change.

-Pascal

Hi Pascal,
thanks, the model is split up in a hundret layers because of imported dwg’s.
So selecting by layer is not an good option. I’ll try anyway…

Selcting and deleting bad objects didn’t help.