3-Finger trackpad gestures trigger selection rectangle

I set up in settings to alter the display mode to 4 different options using 4 different directional gestures.

Now, when using a 3-Finger trackpad gesture, it works and at the same time it triggers a selection rectangle.
The selection even works after a short second of releasing the finger from the trackpad.


NOT FIXED in the latest Version 6: 6.30.20280.12362, 2020-10-06

Thanks for the report, I filed this as https://mcneel.myjetbrains.com/youtrack/issue/RH-61115

1 Like

Is this bug still happening? I cannot reproduce the steps that I found in:

RH-61115 Three finger gesture macros also cause rectangular window selection

Here are the steps I took to attempt to reproduce this issue:

  1. In macOS System Preferences > Trackpad > More Gestures, uncheck the Mission Control to disable the macOS Mission Control gestures that would conflict with the report.
  2. Launched Rhino for Mac 7.5 (see build below) and started a new modeling window.
  3. Navigated to Rhino 7 > Preferences > Trackpad > Three Fingers and set
    the first one - Swipe left with three fingers to run this macro to: !_Box C 0 50 50 50.
  4. In the modeling window, I swiped left with three fingers. A box was created at the origin, as expected.
  5. Navigated to Rhino 7 > Preferences > Trackpad > Three Fingers and set them to vg, vs, vt, and vr respectively (as in @msmr’s helpful report).
  6. Navigated to Rhino 7 > Preferences > Aliases, and set the corresponding “viewport” aliases to those shown in the same report.
  7. In the Rhino viewport, swiped left, right, up, and down with three fingers and the viewport mode switched accordingly without any selection rectangle.

I attempted this with this build on this Mac:

Rhino 7 SR5 2021-4-10 (Rhino 7, 7.5.21100.03002, Git hash:master @ 2cd158094b595f6400479d7cbe511454b6149527)

Apple Intel 64-bit macOS Version 11.3 (Build 20E232) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro13,3
Language: en-US (MacOS default)

What am I doing wrong here? What’s different about our setups?

Not sure.

  • Just reproducing … on Rhino7 v7.6, happens again
  • … switching off bettertouchtool didn´t help either
  • Just reproducing … on Rhino7 v7.7, happens again
  • BUT: I remembered setting this in Accessability > [Zeigersteuerung] “Pointer …” > Trackpad options > [german] “Bewegung aktivieren” > “mit 3 Fingern bewegen” (move with 3 fingers). Switching that off made it work as expected.

So, this might be not an error, as I had set it up that way. Not sure, if that´s what should happen when set that way.

Expected behaviour in macOS, as I remember, is: When activated, you can move a finder window hovering over the top section (where you can grab a window by mouse) and move it with three fingers on the trackpad moving …

Sorry for the possible inconvenience …

No problem. I’m glad you figured out what the culprit is. I can confirm that I do not have that option enabled…

I can understand why that would conflict.