Bug: Trackpad swipes don't work in Rhino OSX


#1

I set up a few macros to run when I three finger swipe in rhino. I know these macros work because I’ve used them before in Rhino OSX. When try and swipe to activate these macros nothing happens. The two finger pan and rotate work fine but the swipes don’t appear to do anything.
I’m running Wenatchee 2013-12-02 (492) under OS X 10.8.5 on my early 2011 Macbook Pro.


(Marlin Prowell) #2

See http://wiki.mcneel.com/rhino/mac/userinterfacefeatures - Trackpad features. You likely have not disabled the OS X default trackpad gestures.


(Brian James) #3

I found I had to disable both ‘Swipe between full screen apps’ and ‘Mission Control’ to get it to work well. Both of these are three finger gestures. The ToggleLeftSidebar and ToggleRightSidebar are pretty nice though as gestures when using the single modeling window.


#4

I tried disabling the default OS X trackpad gestures but that had no effect.


#5

I also disabled all of the OSX trackpad gestures, even the ones that didn’t use three fingers but that still didn’t do anything. Like @BrianJ I would like to set up the ToggleRightSidebar to be triggered by the three finger swipe.


(Marlin Prowell) #6

I cannot duplicate what you are describing.

Try turning off every single option in System Preferences > Trackpad except Scroll direction: natural.

Are you testing this by having the Rhino > Preferences > Trackpad panel open and performing the gestures there?


#7

I turned off all of the options in System Preferences > Trackpad except Scroll direction: natural. After that I tried the three finger swipes and none of them worked with the Rhino > Preferences > Trackpad panel open or closed. Strangely all of the four finger swipes worked fine with both the Rhino > Preferences > Trackpad panel open and closed.