2d drawing fails (partly)

I am just finishing some working drawings from a 3d model of a coffee table, basic dimensions etc in there, when I choose the create 2d drawing option part of the main table top is failing to show ??

This is the 3dm file, is there something in the way I have constructed it to create this fail in the 2d drawing command ? Walnut:Brass Low Table.3dm (290.3 KB)

Hi Miles - thanks, I see that on the mac side, plan view, it gets it better on Windows, as far as I can see, I’ll see if I can figure it out. The truncated/clipped perspective view is due to that viewport framing the table that way - if you zoom extents in all views, that part should look better.



Hi Pascal, I zoom extents all windows before selecting the 2d drawing command, I’ve just drawn up a similiar model, a slightly smaller but taller side table, and the same result happened when I tried to create a 2d drawing ?? When I export to illustrator to print the drawings out, the parts are missing from the drawings ?? They basically look incomplete, parts missing ! @pascal the problem just seems to be in that top view ??

I’m seeing no problems when selecting only the main parts (this is the way I’m usually doing the make2d command).

Hi Toby, it’s done the same in 2 of my models today, for some reason it’s omitting the smaller section of the table top, in the top view window , scratching my head over something I’m sure is very simple ! @Toby thanks for trying it out on your machine, appreciated :slight_smile:

How do you select to get this weird result? Select All? What are your Make2D settings?
Above you can see with (left) and without (right) invisible lines, but both only with selected legs and both top parts.

@Toby yes I select all, then 2d drawing command, I need the 4 view ‘orthographic’ drawings to print out, it’s just the top view window which seems to be omitting part of the top

@pascal @Toby think I’ve sorted it, I needed to check the ‘show tangent edges’ in the 2d drawings option box :slight_smile:

As far as I can see, yes.


That could be it, I usually have that set but I may not have on Mac, being a Windowsy sort most of the time…



1 Like

Yes, unchecked I’m getting the same weird result.

1 Like

yep thats definitely, just run both models through 2d drawing command and they are fine now, many thanks guys

@pascal @Toby is there another way to print my 2d drawings straight from Rhino instead of importing them to illustrator ?

I’m doing the Illustrator way because all my templates are done with Illu and I have a nice dimension PlugIn.

In the WIP you can use Layout for some nice output.

1 Like

@Toby I’ve not used the WIP for a while, just the initial release version which we purchased last year, just getting a PDF file quicker than exporting to illustrator would be good :slight_smile: