1:1 Plotter prints wider than printer

Hi Everyone,

I want to know if I’ve missed it or if it is a new feature on version 7. I’m using 6.

I’m printing large 1:1 designs on a 42" HP plotter. I can set the paper size to the length of the part I am printing each time. (Usually about 4/5m long) Is there any way to do this automatically when setting the window size? It’s slow going having to change the paper size between plots.

Some of the prints are also wider than the plotter and need to be split. This again is a slow manual process. I have read it’s possible to save as a PDF and Adobe will do this. Can Rhino? I’m sure people have been asking for a while!

All the best… Thanks for your input.

Hi Ben!
Welcome to the forum!

You could set up a rectangle curve (with maybe print width set to “noprint”) as container for your elements to print and then launch a script that takes your rectangle as input (boundingbox?) to set correct sizes to a layout.

You can set up setting by calling -_LayoutProperties …
See this: Printer Settings issues

Some scripting needed.
Feel free to ask for help.
I rarely print…

Here the script, put it inside a button. Just select a rectangle curve:

-runscript (

Sub SetLayoutToRectangle
rec = Rhino.GetObject("Select rectangle",4)
If Not IsNull(rec) Then
box = Rhino.BoundingBox(rec)
p0 = box(0)
p6 = box(6)
Rhino.Command("-_Print s d a "+CStr(p6(0)-p0(0))+" "+CStr(p6(1)-p0(1))+" _Enter v s i w "+Rhino.Pt2Str(p0)+" "+Rhino.Pt2Str(p6)+" _Enter c 1.0 _Enter _Enter p ")
End If
End Sub