Line width when printing to PDF


#1

Hi All,

I’m trying to print a design to PDF that’s going to a Fab shop and they specify that all lines need to be 0.3pt (0.00416in or 0.10566mm). I’ve tried to set the Print Width to hairline but it is still too thick. Is there anyway to specifically specify the width of lines?

Thanks in advance
Michael


#2

Yes, most people don’t realize it, but you can actually type a value into the Print width box in Properties. There is a bug in the current version of Rhino whereby the box does not show values smaller than 0.01 (fixed for the next version), but if you type in a value smaller than that, it is applied to the object - it just shows up as 0.00 in the Print with box…

Otherwise, print widths are settable via script as well.

HTH, --Mitch


#3

Hi Michael,

If I remember this correctly, “hairline” is defined as a single dot width. In order to print this at 0.1 mm width, your printer has to be set at 254 dots per inch. I can check that information in the printing UI, mine is set at 300x300. I would not know how to change that though, but at least you can check yours.
Even if you specify 0.1 mm width in the way Mitch has suggested, obviously the DPI value has to be large enough to print it correctly.

Max.


#4

You mean rh50.SR14?? Or the rh60.WIP??


#5

The current version of Rhino is V5… The release version is still SR12 AFAIK. SR13 is in release candidate stage. There is no SR14 (yet).


#6

Thanks for the response, the only way I see to enter in value is on the Properties->Display Modes->Curve Width. When I enter in the value 0.00416 it shows 0 then when I print to PDF it’s an empty file. Am I missing another way to enter the curve width? If I go to the object property, it doesn’t allow me to type in a value. I’ve tried this on V5 and WIP.

Cheers
Michael


#7

sorry; I have my updater set to download RC’s … that’s what caused the confusion for me…

Thanks


(Wim Dekeyser) #8

I’m not sure where you’re at on that one - but I’m not on a Mac.

In the Windows version, one right-clicks on a layer in the Layer Manager and goes to Set Properties > Print Width…. There’s a list of predefined print widths but you can type in a value in the Width: box.

If you leave the width set to Default for the layer, you can set that default width to some number in the Print Setup dialog box under Linetypes and Line Widths.

Not sure if this helps…


#9

That is the screen display width in pixels, nothing to do with printing width.

Max.


#10

On the mac, there doesn’t seem to be a way to enter in a value for the print width. It is a drop down box with no option to type in a value. Am I missing something?


(Wim Dekeyser) #11

You are probably not missing anything - I am assuming that you have tried it.
Is it a read-only pull-down box in both places? In the for Windows version, it is a pull-down in the Print Setup but you can still enter a number into it as well. @dan, @marlin, is this missing in the for Mac?


#12

Yeah, looks like none of this is hooked up on Mac currently… :unamused:

Even the macro

_-Properties _Object _PrintLinewidth 0.01 !

does not work, nothing is hooked up in object -Properties except visibility…

–Mitch


(Dan Belcher) #13

Apologies for the slow uptake…

Yes, indeed, it seems this is missing in Rhino for Mac. Added to the pile (MR-2725).

Thanks for reporting!


#14

Is there any resolution for this on Mac?
I can change my print width in the drop down bar but it resets itself each time. Any way I can set a width as standard for my drawings or just change it and make it stay?


(Dan Belcher) #15

Sorry to say that this item is not slated to be fixed until Rhino 6 for Mac.