Zoom and Display Bug?

I have no idea what’s going on with Rhino 7 (7.0.20217.3575, 8/4/2020) but something seems to be broken with zoom and display.

There seems to be a cascading series of related problems. I can’t see geometry in my viewport but I can select it. I can’t create any geometry in the viewport via the mouse, but I can with the command line. I can’t zoom either extents or selected.

I was working in GH and somehow I accidentally made something massive (10^65 units!!!). After this disaster finished calculating, everything in GH and Rhino disappeared from the viewport. I deleted the bad GH components that made that gigantic thing and still no luck. I tried selecting something via the layer palette that I had made before that I new was small and zoom selected. Despite the command line saying I had a surface selected, when I Zoom Selected, it said I didn’t have anything selected.

As a test, I made a box 100 units per side via the command line and exported it to a new Rhino 7 file. Closed GH and Rhino and then restarted and opened the Box.3dm file (attached). All of the problems still exist in this file. I can select the box either selecting via the Layer or by command line. But the box doesn’t appear on in the viewport except for the gumball. If I try to ZoomSel, it says I don’t have anything selected. See screenshots of “selected” geometry and then the error in zooming.

If I try to create any new geometry in the viewport, I just get the prohibited mouse icon. In 17 years of Rhino use, this bug is new. I know really large objects or objects that are far from the origin can cause Rhino to freak out, but the only object in this file is a 100 unit box at the origin so clearly something else is going on.

box.3dm (1.3 MB)

what’s this setting look like on your rig?

Here the same problem inside Rhino 6 SR28.
Zooming and rotating is loosing model thought viewport space.
I can only reach model again if i select objects by material name and zoom selected

The zoom scale factor is 0.9.

If I open a new file and start from scratch, all is normal. But if I open that file, everything goes back to what I described and I can’t see or zoom to any geometry.

Run 4View twice (right-click) to replace your 4 viewports:

Also your tolerance is borked:

My visual clue was no coordinate display in your screenshots.

Interesting! Thanks. Strange that creating something super large in GH would change this rhino options.