Zoo Slow To Release License


#1

Hello.

Zoo is slow to release licenses after closing Rhino. Sometimes it can take upwards of 10 minutes to release the license after one user closes the program. Is there anyway to increase the speed at which this process occurs. Our office is often trading licenses throughout the day and waiting 10 minutes to free up the license is a long time.

Thanks,
Chris


(John Brock) #2

It should not take that long unless the user is closing the lid on a running session. Then the Zoo’s “Recover orphaned licenses…” tool comes into play.

image

Are you sure it’s not just a slow web page refresh?
Test it.
With the Zoo console open, have a user close Rhino, and give it 30 seconds or so and tap F5 or click the Refresh icon on the Zoo console. Their license should become available when you refresh the console.


#3

Thanks John.


#4

Sorry, I read your post wrong the first time. The typical user does not have access to the server however they do enter the servername/status into their web browser to check the status of the licenses. After Rhino is properly closed the licenses still shows up as in use for an extended period of time. Refreshing does not help. I’m guessing that the reason the license does eventually free itself is because it hits the time limit of the recovered orphan license timer. I can request that the timer be lowered, but from what I think your saying that’s kind of a workaround to free the license as in it should just free itself once the user closes Rhino.


(John Brock) #5

Yes, it should free up within a few seconds when the user Quits (Cmd+Q) out of Rhino.
Closing the file is not enough to free up the application license.

Is that a possibility?


#6

Yea its hard to pin down because it is inconsistent. Most of the time it does release quickly, but sometimes it doesn’t. Usually people just hit the ‘X’ at the top right corner to close the program. Next time it happens I will try to use Cmd+Q and let you know if that helps. Its not doing it right now so I cant test.

Thanks.


(John Brock) #7

Right.
As long as there is a Rhino application icon in the Dock with an arrow in it indicating Rhino is running, it will be holding on to a license.


#8

I’m having exactly the same issue with Zoo 6SR5. Checked in an R6 license more than an hour ago, but it’s still shown as ‘Checked Out’. My admin re-started Zoo, but to no avail. We have now changed the check-out period from 30 days to 1 day, hoping that the license will become available tomorrow. Or ‘orphan’ period is set to 15 minutes.


(Wim Dekeyser) #9

Are you sure there isn’t a running instance of rhino.exe when you check in the Windows Task Manager?


#10

positive. No rhino.exe is running


#11

Same here, no rhino.exe was running. Also I tried opening Rhino again and then closing it hoping it would trigger the release but that didnt work either. The first time it happened I think we restarted the computer as well. We are using zoo_6.0.18009.2393, I downloaded the latest version today and will ask our admin to install and let you know if that helps.


(John Brock) #12

In the Zoo console, select the checked out license and use the license recovery tool.
That’s what it’s for.
Any luck?


#13

My admin has worked out how to do this. He tells me this feature is not very easy to find (it sounds like he was looking for some button).
The license is shown as ‘available’ again. Thank you


(John Brock) #14

The tool not intended to be easy to find so as to not be abused unintentionally.

The Zoo is designed to help honest actors play by the rules in an efficient and easy to manage way. It does that very well.
It is not designed to be punitive.