Yak package list not updating

Hi there,

We have had, over the last month, several (3-4) customers who have been unable to find updates to our Rhino Plugin using the Yak package manager.

When I connect to these machines I am able to run a yak search on the command line and it does indeed report the latest version of our plugin (ZebraCut). However this is not visible within Rhino’s Package Manager.

I have noticed that these machines tend to be the slower machines with poorer internet access.
I also noticed that the package manager update search never seems to complete on these machines - the spinning circles animation does not seem to ever stop spinning.

Sorry I can’t give a more precise bug report but thought I’d throw this out there and see if anyone else has had this or if there is a known issue. Or perhaps it is specific to our plugin?

The solution we’ve had to employ is to un-install and then re-install rhino which works but is rather like using a sledgehammer to crack a nut…

Hi David, is this Rhino 6 or 7? Are they typing into the search bar, or just scrolling to find the package? In the first few service releases of Rhino 7 here was an artificial limit on the number of packages that could be loaded into the UI at any one time. This has since been raised.

Hi Will,

They have all been Rhino 7, I believe all 7.9 or later.
We tried both methods in the UI - just scrolling and searching.
In either case the new version did not appear.


Starting with version 1.2.1, the ZebraCut package is listed as only supporting Rhino 7.10 and later. Was this intentional? When building the package, the Yak tool will inspect the plug-in to see which version of the SDK it was built against. See the note on “distributions” towards the end of “Creating a Grasshopper plug-in package”.

Thanks Will, yeah that was deliberate when we switched to the nuget Rhino package (looking forward to a Yak Nuget package). I agree this could have caused these issues however we encountered them before this change. I suppose it is possible the artificial limit you mentioned might have caused the problem.

I will update this thread if we encounter this again - any files/logs which would be helpful to capture if we see this again?

What would a Yak NuGet package solve for you?

Please do! Just Rhino’s build version (see _SystemInfo command) will be useful as well as knowing if there’s a difference when using the search box to narrow the results. Thanks!

Thanks Will, I’ll report back if we see this again.

I currently reference Yak dll from Rhino’s install in order to do update checking for the user automatically.

However I understood from this thread that referencing this way might be fragile if you increment Yak dll versions. I figured a yak nuget package might give control of which version the plugin works with.

Of course if the package manager did automatic update checking that would be much much better :wink: would be great if it could respect the -beta or -dev tags and only offer updates in the same stream

Hi Will,

Unfortunately we have encountered this problem again - on two separate machines - one running 7R13 and the other 7R14. Our package does now take a dependency on 7R13 but both machines were running that or above.

Both machines had ZebraCut 1.3.7-beta installed and were seeking to upgrade to 1.4.2-dev.
However 1.4.2-dev was not appearing in the Package Manager list under the Version: drop down combo box - this was the case on both the installed and the online tab regardless of whether we searched or scrolled.
Below the system Info for one of the machines
rhino-system-info.txt (2.8 KB)
Our work around was to un-install ZebraCut 1.3.7-beta restart Rhino - after this (e.g. with no package installed) we were able to see 1.4.2-dev in the normal way.

Was the “Include pre-releases” checkbox checked when first looking to see if an update was available?

yes in all cases include pre-release was checked

Thanks. I tried to reproduce this but couldn’t. The pre-release filtering was the only thing that came to mind, so I had to make sure.

Before uninstalling 1.3.7-beta, do you recall seeing other pre-release versions in the drop-down, or was the installed version the only one?

Thanks for taking a look Will. I can confirm all other (previous) pre-release versions were visible in the version drop down before we uninstalled the plugin - it just didn’t see the new version.

To replicate I think you’d need to leave the current version installed while a new version is pushed. I will be pushing a new Dev version in a few hours if it helps?

Otherwise I wondered if it might be specific to us being the final plugin in the list (Z for Zebra)

Thanks for confirming.

I’ve tried again to reproduce the behaviour following this, but in my case simply closing and running PackageManager again is enough to get it to see that there’s an update available.

If it’s finding some of the versions then it should find them all (assuming they’re compatible).

When you next push a new version, please check first that it shows up in the API at https://yak.rhino3d.com/versions/zebracut (it might take a moment for the server-side cache to be cleared). Then run PackageManager and see if it shows the update available. Let me know if it doesn’t show up. I’ve installed 1.4.2-dev, so I’ll be able to try on my machine too.

Thanks Will,

I have just released version 1.4.3-dev and confirmed it is visible on https://yak.rhino3d.com/versions/zebracut and via the yak command line search.

I can confirm that it was immediately found on two different computers and showed as an available update and installed without problems.

So the mystery deepens! I will check a couple of other PC’s and report back if I encounter the same problem.

A final thought - yesterdays issue was for machines trying to upgrade from 1.3.7-beta to 1.4.2-dev. Is it possible that Rhino thinks that is a downgrade and so does not show it?

Just a quick update, we have tried to update two further machines (4 in total this morning) - problem appeared on 2 of 4.

First machine:

  • Running 7R13 and 1.4.2-dev
  • Could not find 1.4.3-dev to start with
  • it appeared after reopening package manager

Second machine:

  • Running 7R13 and 1.3.7-beta
  • Could not find 1.4.3-dev
  • did not appear after a restart of package manager
  • Only appeared after uninstalling 1.3.7-beta

Thanks for the update. 1.4.3-dev showed up on my machine too after reopening the package manager.

Sorry, I know it’s tedious but I have a few more questions to try to determine a pattern here…

  • Did the same machine that had problems this morning also fail to show the 1.4.2-dev update?
  • Can you reproduce the behaviour on the machine by downgrading to 1.3.7-dev and restarting Rhino?

Also, just to confirm a couple of things:

  • Reopening the package manager is necessary to get it to refresh the list of packages and versions.
  • 1.4.2-dev is considered higher than 1.3.7-beta because the version number is higher. We follow Semantic Versioning (whilst also supporting Microsoft-style four-digit version numbers).

No problem Will, thanks for the confirmations.

The same PCs have both had succeeded and failed (from 1.3.7-beta > 1.4.2-dev failed but 1.4.2-dev > 1.4.3-dev succeeded) some have failed on both (from 1.3.7-beta > 1.4.2-dev failed and 1.4.2-dev > 1.4.3-dev failed)

I can confirm I can replicate the issue by re-installing 1.3.7-beta and then I am unable to see 1.4.x-dev in the list (even after reopening the package manager) - when I uninstall all versions become visible.